{"answers":{"affected":"2 open source packages ship an affected version, including @lambda-middleware/json-deserializer. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-4437 exists.","fix":"Upgrade @lambda-middleware/json-deserializer to 1.1.0 or later.","what":"CVE-2021-4437 is a low-severity denial of service vulnerability in dbartholomae lambda-middleware frameguard, published on 12 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-4437 and fix it if it is affected.\n\nWhat it is: CVE-2021-4437 is a low-severity denial of service vulnerability in dbartholomae lambda-middleware frameguard, published on 12 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-4437 exists.\n\nAffected packages and fixed versions:\n- @lambda-middleware/json-deserializer (npm): affected all versions; fixed in 1.1.0\n- @lambda-middleware/json-deserializer (npm): affected all versions; fixed in 1.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-4437/ (Markdown: https://insights.sbomify.com/CVE-2021-4437/index.md)","id":"CVE-2021-4437","markdown":"https://insights.sbomify.com/CVE-2021-4437/index.md","name":"CVE-2021-4437","record":{"aliases":["GHSA-m3f4-957x-m785"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Node.js middleware library","requires_auth":"low_privilege","summary":"An attacker can cause a denial of service via inefficient regular expression complexity in the JSON deserializer of the lambda-middleware frameguard library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"lambda-middleware","vendor":"dbartholomae"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"A vulnerability, which was classified as problematic, has been found in dbartholomae lambda-middleware frameguard up to 1.0.4. Affected by this issue is some unknown functionality of the file packages/json-deserializer/src/JsonDeserializer.ts of the component JSON Mime-Type Handler. The manipulation leads to inefficient regular expression complexity. Upgrading to version 1.1.0 is able to address this issue. The patch is identified as f689404d830cbc1edd6a1018d3334ff5f44dc6a6. It is recommended to upgrade the affected component. VDB-253406 is the identifier assigned to this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"dbartholomae lambda-middleware frameguard JSON Mime-Type JsonDeserializer.ts redos","id":"CVE-2021-4437","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":5,"next":{"headline":"React Native Sms User Consent Intent Redirection Vulnerability","id":"CVE-2021-4438"},"packages":[{"ecosystem":"npm","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"@lambda-middleware/json-deserializer","purl":null,"source":"GHSA-m3f4-957x-m785"},{"ecosystem":"npm","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"@lambda-middleware/json-deserializer","purl":"pkg:npm/%40lambda-middleware/json-deserializer","source":"GHSA-m3f4-957x-m785"}],"prev":{"headline":"3DPrint Lite \u003c 1.9.1.5 - Unauthenticated Arbitrary File Upload","id":"CVE-2021-4436"},"products":["lambda-middleware frameguard"],"published":"2024-02-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-06","vendors":["dbartholomae"]},"summary":"An attacker can cause a denial of service via inefficient regular expression complexity in the JSON deserializer of the lambda-middleware frameguard library.","url":"https://insights.sbomify.com/CVE-2021-4437/"}