CVE-2021-4445 Premium Addons for Elementor <= 4.5.1 - Authenticated (Subscriber+) Limited Arbitrary Option Update
Authenticated subscribers can arbitrarily update specific WordPress options due to missing capability checks in the Premium Addons for Elementor plugin.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2021-4445?
CVE-2021-4445 is a medium-severity missing authorization vulnerability in leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets, published on 16 Oct 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
The Premium Addons for Elementor plugin for WordPress is vulnerable to Arbitrary Option Updates in versions up to, and including, 4.5.1. This is due to missing capability and nonce checks in the pa_dismiss_admin_notice AJAX action. This makes it possible for authenticated subscriber+ attackers to change arbitrary options with a restricted value of 1 on vulnerable WordPress sites.
Weakness: CWE-862
Which versions are affected by CVE-2021-4445?
It affects 1 product.
Products include Leap13 Premium Addons for Elementor.
How do I fix CVE-2021-4445?
No fix has been published for CVE-2021-4445 yet. Limit exposure of the affected software until one is available.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2021-4445 being exploited?
There is no known exploitation of CVE-2021-4445 in the wild and no public exploit code.
Other vulnerabilities in leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets
- CVE-2023-34012 WordPress Premium Addons PRO Plugin <= 2.8.24 is vulnerable to Cross Site Scripting (XSS)
- CVE-2024-37922 WordPress Premium Addons for Elementor plugin <= 4.10.34 - Cross Site Scripting (XSS) vulnerability
- CVE-2024-32791 WordPress Premium Addons for Elementor plugin <= 4.10.25 - Cross Site Scripting (XSS) vulnerability
- CVE-2024-29106 WordPress Premium Addons for Elementor plugin <= 4.10.16 - Cross Site Scripting (XSS) vulnerability
- CVE-2024-24831 WordPress Premium Addons for Elementor plugin <= 4.10.16 - Cross Site Scripting (XSS) vulnerability
Sources
Also known as GHSA-3368-73h5-mjmr.