{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-4445 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2021-4445 yet. Limit exposure of the affected software until one is available.","what":"CVE-2021-4445 is a medium-severity missing authorization vulnerability in leap13 Premium Addons for Elementor – Powerful Elementor Templates \u0026 Widgets, published on 16 Oct 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-4445 and fix it if it is affected.\n\nWhat it is: CVE-2021-4445 is a medium-severity missing authorization vulnerability in leap13 Premium Addons for Elementor – Powerful Elementor Templates \u0026 Widgets, published on 16 Oct 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-4445 in the wild and no public exploit code.\n\nAffected product: leap13 Premium Addons for Elementor – Powerful Elementor Templates \u0026 Widgets. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-4445/ (Markdown: https://insights.sbomify.com/CVE-2021-4445/index.md)","id":"CVE-2021-4445","markdown":"https://insights.sbomify.com/CVE-2021-4445/index.md","name":"CVE-2021-4445","record":{"aliases":["GHSA-3368-73h5-mjmr"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated subscribers can arbitrarily update specific WordPress options due to missing capability checks in the Premium Addons for Elementor plugin.","user_interaction":"required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"premium_addons_for_elementor","vendor":"leap13"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"The Premium Addons for Elementor plugin for WordPress is vulnerable to Arbitrary Option Updates in versions up to, and including, 4.5.1. This is due to missing capability and nonce checks in the pa_dismiss_admin_notice AJAX action. This makes it possible for authenticated subscriber+ attackers to change arbitrary options with a restricted value of 1 on vulnerable WordPress sites.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Premium Addons for Elementor \u003c= 4.5.1 - Authenticated (Subscriber+) Limited Arbitrary Option Update","id":"CVE-2021-4445","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2021"},"n_packages":0,"n_references":5,"next":{"headline":"Essential Addons for Elementor \u003c= 4.6.4 - Missing Authorization","id":"CVE-2021-4446"},"packages":[],"prev":{"headline":"Product Filter by WooBeWoo \u003c= 1.4.9 - Missing Authorization","id":"CVE-2021-4444"},"products":["Premium Addons for Elementor – Powerful Elementor Templates \u0026 Widgets"],"published":"2024-10-16","related":[{"cvss_score":7.1,"headline":"WordPress Premium Addons PRO Plugin \u003c= 2.8.24 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-34012","kev_date_added":null,"published":"2023-06-23"},{"cvss_score":6.5,"headline":"WordPress Premium Addons for Elementor plugin \u003c= 4.10.34 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-37922","kev_date_added":null,"published":"2024-07-20"},{"cvss_score":6.5,"headline":"WordPress Premium Addons for Elementor plugin \u003c= 4.10.25 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-32791","kev_date_added":null,"published":"2024-04-24"},{"cvss_score":6.5,"headline":"WordPress Premium Addons for Elementor plugin \u003c= 4.10.16 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-29106","kev_date_added":null,"published":"2024-03-19"},{"cvss_score":6.5,"headline":"WordPress Premium Addons for Elementor plugin \u003c= 4.10.16 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-24831","kev_date_added":null,"published":"2024-02-10"},{"cvss_score":6.4,"headline":"Premium Addons for Elementor \u003c= 4.10.69 - Authenticated (Contributor+) Stored Cross-Site Scripting","id":"CVE-2024-11937","kev_date_added":null,"published":"2025-07-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["leap13"]},"summary":"Authenticated subscribers can arbitrarily update specific WordPress options due to missing capability checks in the Premium Addons for Elementor plugin.","url":"https://insights.sbomify.com/CVE-2021-4445/"}