# CVE-2021-4445: Premium Addons for Elementor <= 4.5.1 - Authenticated (Subscriber+) Limited Arbitrary Option Update

> Authenticated subscribers can arbitrarily update specific WordPress options due to missing capability checks in the Premium Addons for Elementor plugin.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 16 Oct 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-3368-73h5-mjmr

## What is CVE-2021-4445?

CVE-2021-4445 is a medium-severity missing authorization vulnerability in leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets, published on 16 Oct 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The Premium Addons for Elementor plugin for WordPress is vulnerable to Arbitrary Option Updates in versions up to, and including, 4.5.1. This is due to missing capability and nonce checks in the pa_dismiss_admin_notice AJAX action. This makes it possible for authenticated subscriber+ attackers to change arbitrary options with a restricted value of 1 on vulnerable WordPress sites.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2021-4445?

It affects 1 product.


Products: Leap13 Premium Addons for Elementor.

## How do I fix CVE-2021-4445?

No fix has been published for CVE-2021-4445 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-4445 being exploited?

There is no known exploitation of CVE-2021-4445 in the wild and no public exploit code.

## Other vulnerabilities in leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets

- [CVE-2023-34012](https://insights.sbomify.com/CVE-2023-34012/): WordPress Premium Addons PRO Plugin <= 2.8.24 is vulnerable to Cross Site Scripting (XSS) (high 7.1)
- [CVE-2024-37922](https://insights.sbomify.com/CVE-2024-37922/): WordPress Premium Addons for Elementor plugin <= 4.10.34 - Cross Site Scripting (XSS) vulnerability (medium 6.5)
- [CVE-2024-32791](https://insights.sbomify.com/CVE-2024-32791/): WordPress Premium Addons for Elementor plugin <= 4.10.25 - Cross Site Scripting (XSS) vulnerability (medium 6.5)
- [CVE-2024-29106](https://insights.sbomify.com/CVE-2024-29106/): WordPress Premium Addons for Elementor plugin <= 4.10.16 - Cross Site Scripting (XSS) vulnerability (medium 6.5)
- [CVE-2024-24831](https://insights.sbomify.com/CVE-2024-24831/): WordPress Premium Addons for Elementor plugin <= 4.10.16 - Cross Site Scripting (XSS) vulnerability (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4445 and fix it if it is affected.

What it is: CVE-2021-4445 is a medium-severity missing authorization vulnerability in leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets, published on 16 Oct 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-4445 in the wild and no public exploit code.

Affected product: leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4445/ (Markdown: https://insights.sbomify.com/CVE-2021-4445/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4445
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4445
- OSV: https://osv.dev/vulnerability/CVE-2021-4445

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4445/
Summaries are generated and may contain mistakes; the official description above is the record.
