CVE-2021-44451 API sensitive information leak
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2021-44451?
CVE-2021-44451 is a medium-severity vulnerability in Apache Superset, published on 1 Feb 2022.
Official description
Apache Superset up to and including 1.3.2 allowed for registered database connections password leak for authenticated users. This information could be accessed in a non-trivial way. Users should upgrade to Apache Superset 1.4.0 or higher.
Weakness: CWE-522
Which versions are affected by CVE-2021-44451?
4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache-superset PyPI | All versions | 1.4.0 |
apache-superset PyPI | All versions | 1.4.0 |
apache-superset PyPI | All versions | 1.4.0 |
superset Bitnami | All versions | 1.3.3 |
Products include Apache Superset.
How do I fix CVE-2021-44451?
Upgrade apache-superset to 1.4.0 or later.
Is CVE-2021-44451 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-44451 exists.
Public exploit code: 1 Nuclei template.
Other vulnerabilities in Apache Superset
- CVE-2023-27524 Apache Superset Insecure Default Initialization of Resource
- CVE-2022-27479 SQL injection vulnerability in chart data API
- CVE-2018-8021 Deserialization of Untrusted Data in superset
- CVE-2023-49657 Apache Superset: Stored XSS in Dashboard Title and Chart Title
- CVE-2022-43719 Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API
Sources
Also known as BIT-superset-2021-44451, GHSA-hhm3-48h2-597v, PYSEC-2022-36.