# CVE-2021-44451: API sensitive information leak


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 1 Feb 2022
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-superset-2021-44451, GHSA-hhm3-48h2-597v, PYSEC-2022-36

## What is CVE-2021-44451?

CVE-2021-44451 is a medium-severity vulnerability in Apache Superset, published on 1 Feb 2022. 

### Official description

Apache Superset up to and including 1.3.2 allowed for registered database connections password leak for authenticated users. This information could be accessed in a non-trivial way. Users should upgrade to Apache Superset 1.4.0 or higher.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2021-44451?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 1.4.0 |
| `apache-superset` | PyPI | All versions | 1.4.0 |
| `apache-superset` | PyPI | All versions | 1.4.0 |
| `superset` | Bitnami | All versions | 1.3.3 |

Products: Apache Superset.

## How do I fix CVE-2021-44451?

Upgrade apache-superset to 1.4.0 or later.

## Is CVE-2021-44451 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-44451 exists.

Public exploit code:

- Apache Superset <=1.3.2 - Default Login (nuclei): http/cves/2021/CVE-2021-44451.yaml

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-44451 and fix it if it is affected.

What it is: CVE-2021-44451 is a medium-severity vulnerability in Apache Superset, published on 1 Feb 2022. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-44451 exists.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 1.4.0
- apache-superset (PyPI): affected all versions; fixed in 1.4.0
- apache-superset (PyPI): affected all versions; fixed in 1.4.0
- superset (Bitnami): affected all versions; fixed in 1.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-44451/ (Markdown: https://insights.sbomify.com/CVE-2021-44451/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-44451
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-44451
- OSV: https://osv.dev/vulnerability/CVE-2021-44451

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-44451/
Summaries are generated and may contain mistakes; the official description above is the record.
