# CVE-2021-44528: actionpack Open Redirect in Host Authorization Middleware

> Attackers can redirect users to malicious sites via crafted headers in Action Pack when specific host authorization settings are enabled.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Jan 2022
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-rails-2021-44528, DEBIAN-CVE-2021-44528, GHSA-qphc-hf5q-v8fc, UBUNTU-CVE-2021-44528

## What is CVE-2021-44528?

CVE-2021-44528 is a medium-severity vulnerability in Rubyonrails Rails, published on 7 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A open redirect vulnerability exists in Action Pack >= 6.0.0 that could allow an attacker to craft a "X-Forwarded-Host" headers in combination with certain "allowed host" formats can cause the Host Authorization middleware in Action Pack to redirect users to a malicious website.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2021-44528?

5 open source packages ship an affected version, including rails and actionpack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rails` | Bitnami | From 7.0.0-rc2 to 7.0.0-rc2 | None |
| `actionpack` | RubyGems | From 6.0.0 | 6.0.4.2 |
| `actionpack` | RubyGems | From 6.0.0 | 6.0.4.2 |
| `actionpack` | RubyGems | From 6.1.0 | 6.1.4.2 |
| `actionpack` | RubyGems | From 6.1.0 | 6.1.4.2 |

Products: Rubyonrails Rails.

## How do I fix CVE-2021-44528?

Apply the vendor's patch.

## Is CVE-2021-44528 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-44528 exists.

Public exploit code:

- Open Redirect in Host Authorization Middleware (nuclei): http/cves/2021/CVE-2021-44528.yaml

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-44528 and fix it if it is affected.

What it is: CVE-2021-44528 is a medium-severity vulnerability in Rubyonrails Rails, published on 7 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-44528 exists.

Affected packages and fixed versions:
- rails (Bitnami): affected from 7.0.0-rc2 up to 7.0.0-rc2; no fix listed
- actionpack (RubyGems): affected from 6.0.0; fixed in 6.0.4.2
- actionpack (RubyGems): affected from 6.0.0; fixed in 6.0.4.2
- actionpack (RubyGems): affected from 6.1.0; fixed in 6.1.4.2
- actionpack (RubyGems): affected from 6.1.0; fixed in 6.1.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-44528/ (Markdown: https://insights.sbomify.com/CVE-2021-44528/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-44528
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-44528
- OSV: https://osv.dev/vulnerability/CVE-2021-44528

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-44528/
Summaries are generated and may contain mistakes; the official description above is the record.
