# CVE-2021-44531: Security feature bypass in Node

> Node.js accepted URI Subject Alternative Names, allowing attackers to bypass name-constrained intermediates and potentially impersonate hosts.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2022
- **Updated:** 30 Apr 2025
- **Also known as:** ALPINE-CVE-2021-44531, AZL-8840, BIT-node-2021-44531, BIT-node-min-2021-44531, CLEANSTART-2026-LA76533, CLEANSTART-2026-LY78123, CLEANSTART-2026-YI32542, DEBIAN-CVE-2021-44531, GHSA-5qpf-4xwh-5775

## What is CVE-2021-44531?

CVE-2021-44531 is a high-severity vulnerability in Nodejs Node.js, published on 24 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Accepting arbitrary Subject Alternative Name (SAN) types, unless a PKI is specifically defined to use a particular SAN type, can result in bypassing name-constrained intermediates. Node.js < 12.22.9, < 14.18.3, < 16.13.2, and < 17.3.1 was accepting URI SAN types, which PKIs are often not defined to use. Additionally, when a protocol allows URI SANs, Node.js did not match the URI correctly.Versions of Node.js with the fix for this disable the URI SAN type when checking a certificate against a hostname. This behavior can be reverted through the --security-revert command-line option.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2021-44531?

2 open source packages ship an affected version, including node and node-min. It affects 8 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | All versions | 12.22.9, 14.18.3, 16.13.2, 17.3.1 |
| `node-min` | Bitnami | All versions | 12.22.9, 14.18.3, 16.13.2, 17.3.1 |

Products: Nodejs Node.js, Oracle Graalvm, Oracle Mysql Cluster, Oracle Mysql Connectors, Oracle Mysql Enterprise Monitor, Oracle Mysql Server, Oracle Mysql Workbench, Oracle Peoplesoft Enterprise Peopletools.

## How do I fix CVE-2021-44531?

Upgrade node to a fixed version for your release line: 12.22.9, 14.18.3, 16.13.2 or 17.3.1.

## Is CVE-2021-44531 being exploited?

There is no known exploitation of CVE-2021-44531 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Node.js

- [CVE-2023-32002](https://insights.sbomify.com/CVE-2023-32002/): Security feature bypass in Node (critical 9.8)
- [CVE-2016-6303](https://insights.sbomify.com/CVE-2016-6303/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-15896](https://insights.sbomify.com/CVE-2017-15896/): Security feature bypass in Node.js (critical 9.1)
- [CVE-2018-7160](https://insights.sbomify.com/CVE-2018-7160/): Server-side request forgery in Node.js (high 8.8)
- [CVE-2018-12120](https://insights.sbomify.com/CVE-2018-12120/): Misconfiguration in Node.js (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-44531 and fix it if it is affected.

What it is: CVE-2021-44531 is a high-severity vulnerability in Nodejs Node.js, published on 24 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-44531 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected all versions; fixed in 12.22.9, 14.18.3, 16.13.2, 17.3.1
- node-min (Bitnami): affected all versions; fixed in 12.22.9, 14.18.3, 16.13.2, 17.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-44531/ (Markdown: https://insights.sbomify.com/CVE-2021-44531/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-44531
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-44531
- OSV: https://osv.dev/vulnerability/CVE-2021-44531

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-44531/
Summaries are generated and may contain mistakes; the official description above is the record.
