# CVE-2021-44532: Security feature bypass in Node

> Attackers can bypass certificate name constraints in Node.js by exploiting a SAN injection vulnerability when name constraints are enabled.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2022
- **Updated:** 30 Apr 2025
- **Also known as:** ALPINE-CVE-2021-44532, AZL-8818, BIT-node-2021-44532, BIT-node-min-2021-44532, CLEANSTART-2026-AX13608, CLEANSTART-2026-GQ73643, CLEANSTART-2026-KJ80745, DEBIAN-CVE-2021-44532, GHSA-jg6g-8j59-vr29, UBUNTU-CVE-2021-44532

## What is CVE-2021-44532?

CVE-2021-44532 is a medium-severity vulnerability in Debian Debian Linux, published on 24 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Node.js < 12.22.9, < 14.18.3, < 16.13.2, and < 17.3.1 converts SANs (Subject Alternative Names) to a string format. It uses this string to check peer certificates against hostnames when validating connections. The string format was subject to an injection vulnerability when name constraints were used within a certificate chain, allowing the bypass of these name constraints.Versions of Node.js with the fix for this escape SANs containing the problematic characters in order to prevent the injection. This behavior can be reverted through the --security-revert command-line option.

Weakness: CWE-295 (Improper Certificate Validation), CWE-296 (Improper Following of a Certificate's Chain of Trust)

## Which versions are affected by CVE-2021-44532?

2 open source packages ship an affected version, including node and node-min. It affects 9 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | All versions | 12.22.9, 14.18.3, 16.13.2, 17.3.1 |
| `node-min` | Bitnami | All versions | 12.22.9, 14.18.3, 16.13.2, 17.3.1 |

Products: Debian Debian Linux, Nodejs Node.js, Oracle Graalvm, Oracle Mysql Cluster, Oracle Mysql Connectors, Oracle Mysql Enterprise Monitor, Oracle Mysql Server, Oracle Mysql Workbench, Oracle Peoplesoft Enterprise Peopletools.

## How do I fix CVE-2021-44532?

Upgrade node to a fixed version for your release line: 12.22.9, 14.18.3, 16.13.2 or 17.3.1.

## Is CVE-2021-44532 being exploited?

There is no known exploitation of CVE-2021-44532 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-44532 and fix it if it is affected.

What it is: CVE-2021-44532 is a medium-severity vulnerability in Debian Debian Linux, published on 24 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-44532 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected all versions; fixed in 12.22.9, 14.18.3, 16.13.2, 17.3.1
- node-min (Bitnami): affected all versions; fixed in 12.22.9, 14.18.3, 16.13.2, 17.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-44532/ (Markdown: https://insights.sbomify.com/CVE-2021-44532/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-44532
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-44532
- OSV: https://osv.dev/vulnerability/CVE-2021-44532

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-44532/
Summaries are generated and may contain mistakes; the official description above is the record.
