# CVE-2021-44547: Code injection in Odoo Community

> Authenticated administrators can execute arbitrary code due to a sandboxing flaw, leading to privilege escalation in Odoo.

- **Severity:** High 8.7 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2023
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-odoo-2021-44547, GHSA-6pv9-8vp3-8q9q, UBUNTU-CVE-2021-44547

## What is CVE-2021-44547?

CVE-2021-44547 is a high-severity code injection vulnerability in Odoo Odoo, published on 25 Apr 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A sandboxing issue in Odoo Community 15.0 and Odoo Enterprise 15.0 allows authenticated administrators to executed arbitrary code, leading to privilege escalation.

Weakness: CWE-267 (Privilege Defined With Unsafe Actions)

## Which versions are affected by CVE-2021-44547?

1 open source package ship an affected version, including odoo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `odoo` | Bitnami | All versions | 15.0.1 |

Products: Odoo Odoo.

## How do I fix CVE-2021-44547?

Upgrade odoo to 15.0.1 or later.

## Is CVE-2021-44547 being exploited?

There is no known exploitation of CVE-2021-44547 in the wild and no public exploit code.

## Other vulnerabilities in Odoo Odoo

- [CVE-2020-29396](https://insights.sbomify.com/CVE-2020-29396/): Code injection in Odoo Community (critical 9.9)
- [CVE-2018-14885](https://insights.sbomify.com/CVE-2018-14885/): Auth bypass in n/a (critical 9.8)
- [CVE-2017-10804](https://insights.sbomify.com/CVE-2017-10804/): Auth bypass in n/a (critical 9.8)
- [CVE-2018-14860](https://insights.sbomify.com/CVE-2018-14860/): Code injection in n/a (critical 9.1)
- [CVE-2017-10805](https://insights.sbomify.com/CVE-2017-10805/): Auth bypass in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-44547 and fix it if it is affected.

What it is: CVE-2021-44547 is a high-severity code injection vulnerability in Odoo Odoo, published on 25 Apr 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-44547 in the wild and no public exploit code.

Affected packages and fixed versions:
- odoo (Bitnami): affected all versions; fixed in 15.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-44547/ (Markdown: https://insights.sbomify.com/CVE-2021-44547/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-44547
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-44547
- OSV: https://osv.dev/vulnerability/CVE-2021-44547

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-44547/
Summaries are generated and may contain mistakes; the official description above is the record.
