# CVE-2021-44548: Apache Solr information disclosure vulnerability through DataImportHandler

> Attackers can trigger SMB network calls via UNC paths in DataImportHandler, potentially leaking credentials or enabling remote code execution on Windows hosts.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-solr-2021-44548, GHSA-pccr-q7v9-5f27

## What is CVE-2021-44548?

CVE-2021-44548 is a critical server-side request forgery vulnerability in Apache Solr, published on 23 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An Improper Input Validation vulnerability in DataImportHandler of Apache Solr allows an attacker to provide a Windows UNC path resulting in an SMB network call being made from the Solr host to another host on the network. If the attacker has wider access to the network, this may lead to SMB attacks, which may result in: * The exfiltration of sensitive data such as OS user hashes (NTLM/LM hashes), * In case of misconfigured systems, SMB Relay Attacks which can lead to user impersonation on SMB Shares or, in a worse-case scenario, Remote Code Execution This issue affects all Apache Solr versions prior to 8.11.1. This issue only affects Windows.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-40 (Path Traversal: '\\UNC\share\name\' (Windows UNC Share)), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-44548?

3 open source packages ship an affected version, including org.apache.solr:solr-parent and solr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-parent` | Maven | All versions | 8.11.1 |
| `org.apache.solr:solr-parent` | Maven | All versions | 8.11.1 |
| `solr` | Bitnami | All versions | 8.11.1 |

Products: Apache Solr.

## How do I fix CVE-2021-44548?

Upgrade org.apache.solr:solr-parent to 8.11.1 or later.

## Is CVE-2021-44548 being exploited?

There is no known exploitation of CVE-2021-44548 in the wild and no public exploit code.

## Other vulnerabilities in Apache Solr

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)
- [CVE-2020-13957](https://insights.sbomify.com/CVE-2020-13957/): Incorrect Authorization in Apache Solr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-44548 and fix it if it is affected.

What it is: CVE-2021-44548 is a critical server-side request forgery vulnerability in Apache Solr, published on 23 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-44548 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.solr:solr-parent (Maven): affected all versions; fixed in 8.11.1
- org.apache.solr:solr-parent (Maven): affected all versions; fixed in 8.11.1
- solr (Bitnami): affected all versions; fixed in 8.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-44548/ (Markdown: https://insights.sbomify.com/CVE-2021-44548/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-44548
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-44548
- OSV: https://osv.dev/vulnerability/CVE-2021-44548

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-44548/
Summaries are generated and may contain mistakes; the official description above is the record.
