# CVE-2021-44618: Server-side Template Injection in nystudio107/craft-seomatic

> Attacker can execute arbitrary code via Server-side Template Injection in the Seomatic plugin using the Host header.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2022
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-m3xv-x3ph-mq22

## What is CVE-2021-44618?

CVE-2021-44618 is a critical code injection vulnerability in n/a, published on 11 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Server-side Template Injection (SSTI) vulnerability exists in Nystudio107 Seomatic 3.4.12 in src/helpers/UrlHelper.php via the host header.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2021-44618?

2 open source packages ship an affected version, including nystudio107/craft-seomatic. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nystudio107/craft-seomatic` | Packagist | All versions | 3.4.12 |
| `nystudio107/craft-seomatic` | Packagist | All versions | 3.4.12 |

Products: Nystudio107 Seomatic.

## How do I fix CVE-2021-44618?

Upgrade nystudio107/craft-seomatic to 3.4.12 or later.

## Is CVE-2021-44618 being exploited?

There is no known exploitation of CVE-2021-44618 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-41749](https://insights.sbomify.com/CVE-2021-41749/): Code Injection in SEOmatic (critical 9.8)
- [CVE-2020-12790](https://insights.sbomify.com/CVE-2020-12790/): SEOmatic for CraftCMS allows Server-Side Template Injection (high 7.5)
- [CVE-2018-14716](https://insights.sbomify.com/CVE-2018-14716/): SEOmatic plugin for Craft CMS SSTI Vulnerability (high 7.5)
- [CVE-2021-41750](https://insights.sbomify.com/CVE-2021-41750/): Cross-site Scripting in SEOmatic plugin (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-44618 and fix it if it is affected.

What it is: CVE-2021-44618 is a critical code injection vulnerability in n/a, published on 11 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-44618 in the wild and no public exploit code.

Affected packages and fixed versions:
- nystudio107/craft-seomatic (Packagist): affected all versions; fixed in 3.4.12
- nystudio107/craft-seomatic (Packagist): affected all versions; fixed in 3.4.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-44618/ (Markdown: https://insights.sbomify.com/CVE-2021-44618/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-44618
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-44618
- OSV: https://osv.dev/vulnerability/CVE-2021-44618

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-44618/
Summaries are generated and may contain mistakes; the official description above is the record.
