CVE-2021-44647 Denial of service in n/a

Medium 5.5 Published Updated

A type confusion vulnerability in the Lua library allows local attackers to cause a denial of service via a segmentation fault.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2021-44647?

CVE-2021-44647 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 11 Jan 2022. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Lua v5.4.3 and above are affected by SEGV by type confusion in funcnamefromcode function in ldebug.c which can cause a local denial of service.

Weakness: CWE-843

Which versions are affected by CVE-2021-44647?

1 open source package ship an affected version, including lua. It affects 2 products.

PackageAffectedFixed in
lua BitnamiFrom 5.4.35.4.4

Products include Fedoraproject Fedora, Lua Lua.

How do I fix CVE-2021-44647?

Upgrade lua to 5.4.4 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2021-44647 being exploited?

There is no known exploitation of CVE-2021-44647 in the wild and no public exploit code.

All Fedoraproject Fedora vulnerabilities

Sources

Also known as AZL-41327, AZL-41797, AZL-9317, BIT-lua-2021-44647, DEBIAN-CVE-2021-44647, GHSA-wvx9-9phh-9j3h and 1 more.

Is CVE-2021-44647 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free