{"answers":{"affected":"1 open source package ship an affected version, including lua. It affects 2 products.","exploited":"There is no known exploitation of CVE-2021-44647 in the wild and no public exploit code.","fix":"Upgrade lua to 5.4.4 or later.","what":"CVE-2021-44647 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 11 Jan 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-44647 and fix it if it is affected.\n\nWhat it is: CVE-2021-44647 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 11 Jan 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-44647 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- lua (Bitnami): affected from 5.4.3; fixed in 5.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-44647/ (Markdown: https://insights.sbomify.com/CVE-2021-44647/index.md)","id":"CVE-2021-44647","markdown":"https://insights.sbomify.com/CVE-2021-44647/index.md","name":"CVE-2021-44647","record":{"aliases":["AZL-41327","AZL-41797","AZL-9317","BIT-lua-2021-44647","DEBIAN-CVE-2021-44647","GHSA-wvx9-9phh-9j3h","JLSEC-2026-557"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Lua scripting library","requires_auth":"low_privilege","summary":"A type confusion vulnerability in the Lua library allows local attackers to cause a denial of service via a segmentation fault.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"lua","vendor":"lua"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-843","name":"Access of Resource Using Incompatible Type"}],"description":"Lua v5.4.3 and above are affected by SEGV by type confusion in funcnamefromcode function in ldebug.c which can cause a local denial of service.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2021-44647","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"denial_of_service","year":"2021"},"n_packages":1,"n_references":5,"next":{"headline":"Memory corruption in n/a","id":"CVE-2021-44648"},"packages":[{"ecosystem":"Bitnami","fixed":["5.4.4"],"introduced":["5.4.3"],"last_affected":[],"package":"lua","purl":"pkg:bitnami/lua","source":"BIT-lua-2021-44647"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2021-44632"},"products":["n/a"],"published":"2022-01-11","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"A type confusion vulnerability in the Lua library allows local attackers to cause a denial of service via a segmentation fault.","url":"https://insights.sbomify.com/CVE-2021-44647/"}