# CVE-2021-44832: Apache Log4j2 vulnerable to RCE via JDBC Appender when attacker controls configuration

> Attackers can execute arbitrary code if the logging configuration uses a JDBC Appender with a JNDI LDAP data source URI controlled by the attacker.

- **Severity:** Medium 6.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Dec 2021
- **Updated:** 29 May 2026
- **Also known as:** DEBIAN-CVE-2021-44832, DLA-2870-1, GHSA-8489-44mv-ggj8, MGASA-2022-0002, MINI-3mq3-9fgj-6rpv, OESA-2021-1481, ROOT-APP-MAVEN-CVE-2021-44832, UBUNTU-CVE-2021-44832, openSUSE-SU-2021:4208-1, openSUSE-SU-2022:0002-1, openSUSE-SU-2024:11702-1

## What is CVE-2021-44832?

CVE-2021-44832 is a medium-severity code injection vulnerability in Debian Debian Linux, published on 28 Dec 2021. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Apache Log4j2 versions 2.0-beta7 through 2.17.0 (excluding security fix releases 2.3.2 and 2.12.4) are vulnerable to a remote code execution (RCE) attack when a configuration uses a JDBC Appender with a JNDI LDAP data source URI when an attacker has control of the target LDAP server. This issue is fixed by limiting JNDI data source names to the java protocol in Log4j2 versions 2.17.1, 2.12.4, and 2.3.2.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-44832?

14 open source packages ship an affected version, including org.ops4j.pax.logging:pax-logging-log4j2 and org.apache.logging.log4j:log4j-core. It affects 22 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.ops4j.pax.logging:pax-logging-log4j2` | Maven | From 1.10.0 | 1.10.9 |
| `org.ops4j.pax.logging:pax-logging-log4j2` | Maven | From 1.10.0 | 1.10.9 |
| `org.ops4j.pax.logging:pax-logging-log4j2` | Maven | From 1.11.0 | 1.11.13 |
| `org.ops4j.pax.logging:pax-logging-log4j2` | Maven | From 1.11.0 | 1.11.13 |
| `org.ops4j.pax.logging:pax-logging-log4j2` | Maven | From 1.8.0 | 1.9.2 |
| `org.ops4j.pax.logging:pax-logging-log4j2` | Maven | From 1.8.0 | 1.9.2 |
| `org.ops4j.pax.logging:pax-logging-log4j2` | Maven | From 2.0.0 | 2.0.14 |
| `org.ops4j.pax.logging:pax-logging-log4j2` | Maven | From 2.0.0 | 2.0.14 |
| `org.apache.logging.log4j:log4j-core` | Maven | From 2.0-beta7 | 2.3.2 |
| `org.apache.logging.log4j:log4j-core` | Maven | From 2.0-beta7 | 2.3.2 |
| `org.apache.logging.log4j:log4j-core` | Maven | From 2.13.0 | 2.17.1 |
| `org.apache.logging.log4j:log4j-core` | Maven | From 2.13.0 | 2.17.1 |
| `org.apache.logging.log4j:log4j-core` | Maven | From 2.4 | 2.12.4 |
| `org.apache.logging.log4j:log4j-core` | Maven | From 2.4 | 2.12.4 |
| `log4j` | openSUSE:Leap 15.2 | All versions | 2.17.0-lp152.3.15.1 |
| `log4j` | openSUSE:Leap 15.3 | All versions | 2.17.0-4.16.1 |

Products: Apache Log4j, Cisco Cloudcenter, Debian Debian Linux, Fedoraproject Fedora, Oracle Communications Brm - Elastic Charging Engine, Oracle Communications Diameter Signaling Router, Oracle Communications Interactive Session Recorder, Oracle Communications Offline Mediation Controller, Oracle Flexcube Private Banking, Oracle Health Sciences Data Management Workbench, Oracle Policy Automation, Oracle Policy Automation for Mobile Devices, Oracle Primavera Gateway, Oracle Primavera P6 Enterprise Project Portfolio Management, Oracle Primavera Unifier, Oracle Product Lifecycle Analytics, Oracle Retail Assortment Planning, Oracle Retail Fiscal Management, Oracle Retail Order Broker, Oracle Retail Xstore Point of Service and 2 more.

## How do I fix CVE-2021-44832?

Upgrade org.ops4j.pax.logging:pax-logging-log4j2 to a fixed version for your release line: 1.10.9, 1.11.13, 1.9.2 or 2.0.14.

## Is CVE-2021-44832 being exploited?

There is no known exploitation of CVE-2021-44832 in the wild and no public exploit code.

Public exploit code:

- https://github.com/cckuailong/log4j_RCE_CVE-2021-44832 (github_poc): https://github.com/cckuailong/log4j_RCE_CVE-2021-44832
- Discover Log4Shell vulnerability [CVE-2021-44832] (github_poc): https://github.com/name/log4j-scanner

## Other vulnerabilities in Debian Debian Linux

- [CVE-2021-44228](https://insights.sbomify.com/CVE-2021-44228/): Apache Log4j2 Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-45046](https://insights.sbomify.com/CVE-2021-45046/): Apache Log4j2 Deserialization of Untrusted Data (critical 9.0, exploited in the wild)
- [CVE-2022-23305](https://insights.sbomify.com/CVE-2022-23305/): SQL injection in JDBC Appender in Apache Log4j V1 (critical 9.8)
- [CVE-2017-5645](https://insights.sbomify.com/CVE-2017-5645/): Deserialization of Untrusted Data in Log4j (critical 9.8)
- [CVE-2022-23302](https://insights.sbomify.com/CVE-2022-23302/): Deserialization of untrusted data in JMSSink in Apache Log4j 1.x (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-44832 and fix it if it is affected.

What it is: CVE-2021-44832 is a medium-severity code injection vulnerability in Debian Debian Linux, published on 28 Dec 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-44832 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.ops4j.pax.logging:pax-logging-log4j2 (Maven): affected from 1.10.0; fixed in 1.10.9
- org.ops4j.pax.logging:pax-logging-log4j2 (Maven): affected from 1.10.0; fixed in 1.10.9
- org.ops4j.pax.logging:pax-logging-log4j2 (Maven): affected from 1.11.0; fixed in 1.11.13
- org.ops4j.pax.logging:pax-logging-log4j2 (Maven): affected from 1.11.0; fixed in 1.11.13
- org.ops4j.pax.logging:pax-logging-log4j2 (Maven): affected from 1.8.0; fixed in 1.9.2
- org.ops4j.pax.logging:pax-logging-log4j2 (Maven): affected from 1.8.0; fixed in 1.9.2
- org.ops4j.pax.logging:pax-logging-log4j2 (Maven): affected from 2.0.0; fixed in 2.0.14
- org.ops4j.pax.logging:pax-logging-log4j2 (Maven): affected from 2.0.0; fixed in 2.0.14
- org.apache.logging.log4j:log4j-core (Maven): affected from 2.0-beta7; fixed in 2.3.2
- org.apache.logging.log4j:log4j-core (Maven): affected from 2.0-beta7; fixed in 2.3.2
- org.apache.logging.log4j:log4j-core (Maven): affected from 2.13.0; fixed in 2.17.1
- org.apache.logging.log4j:log4j-core (Maven): affected from 2.13.0; fixed in 2.17.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-44832/ (Markdown: https://insights.sbomify.com/CVE-2021-44832/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-44832
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-44832
- OSV: https://osv.dev/vulnerability/CVE-2021-44832

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-44832/
Summaries are generated and may contain mistakes; the official description above is the record.
