CVE-2021-44855 Cross-site scripting in n/a
Attackers can inject malicious scripts via the Upload Image feature, potentially stealing user sessions or executing code in victim browsers.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-44855?
CVE-2021-44855 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 26 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
An issue was discovered in MediaWiki before 1.35.5, 1.36.x before 1.36.3, and 1.37.x before 1.37.1. There is Blind Stored XSS via a URL to the Upload Image feature.
Weakness: CWE-79
Which versions are affected by CVE-2021-44855?
1 open source package ship an affected version, including mediawiki. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki Bitnami | All versions | 1.35.5, 1.36.3, 1.37.1 |
Products include Mediawiki Mediawiki.
How do I fix CVE-2021-44855?
Upgrade mediawiki to a fixed version for your release line: 1.35.5, 1.36.3 or 1.37.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-44855 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-44855 exists.
Other vulnerabilities in Mediawiki Mediawiki
Sources
Also known as BIT-mediawiki-2021-44855, DEBIAN-CVE-2021-44855, GHSA-3cqw-cf93-mf47, UBUNTU-CVE-2021-44855.