# CVE-2021-44906: Prototype Pollution in minimist

> Attackers can exploit prototype pollution in the Minimist library to potentially execute arbitrary code or escalate privileges.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Mar 2022
- **Updated:** 8 Oct 2026
- **Also known as:** AZL-44583, DEBIAN-CVE-2021-44906, GHSA-xvch-5gv4-984h, MGASA-2023-0035, MINI-hrcg-gx8x-327p, OESA-2022-1665, ROOT-APP-NPM-CVE-2021-44906, UBUNTU-CVE-2021-44906

## What is CVE-2021-44906?

CVE-2021-44906 is a critical vulnerability in n/a, published on 17 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Minimist <=1.2.5 is vulnerable to Prototype Pollution via file index.js, function setKey() (lines 69-95).

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2021-44906?

4 open source packages ship an affected version, including minimist. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `minimist` | npm | All versions | 0.2.4 |
| `minimist` | npm | All versions | 0.2.4 |
| `minimist` | npm | From 1.0.0 | 1.2.6 |
| `minimist` | npm | From 1.0.0 | 1.2.6 |

Products: Substack Minimist.

## How do I fix CVE-2021-44906?

Upgrade minimist to a fixed version for your release line: 0.2.4 or 1.2.6.

## Is CVE-2021-44906 being exploited?

There is no known exploitation of CVE-2021-44906 in the wild and no public exploit code.

Public exploit code:

- https://github.com/nevermoe/CVE-2021-44906 (github_poc): https://github.com/nevermoe/CVE-2021-44906

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-44906 and fix it if it is affected.

What it is: CVE-2021-44906 is a critical vulnerability in n/a, published on 17 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-44906 in the wild and no public exploit code.

Affected packages and fixed versions:
- minimist (npm): affected all versions; fixed in 0.2.4
- minimist (npm): affected all versions; fixed in 0.2.4
- minimist (npm): affected from 1.0.0; fixed in 1.2.6
- minimist (npm): affected from 1.0.0; fixed in 1.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-44906/ (Markdown: https://insights.sbomify.com/CVE-2021-44906/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-44906
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-44906
- OSV: https://osv.dev/vulnerability/CVE-2021-44906

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-44906/
Summaries are generated and may contain mistakes; the official description above is the record.
