{"answers":{"affected":"1 open source package ship an affected version, including limesurvey. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-44967 in the wild and no public exploit code.","fix":"Upgrade limesurvey to 5.2.5 or later.","what":"CVE-2021-44967 is a high-severity vulnerability in Limesurvey Limesurvey, published on 22 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-44967 and fix it if it is affected.\n\nWhat it is: CVE-2021-44967 is a high-severity vulnerability in Limesurvey Limesurvey, published on 22 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-44967 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- limesurvey (Bitnami): affected from 5.2.4; fixed in 5.2.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-44967/ (Markdown: https://insights.sbomify.com/CVE-2021-44967/index.md)","id":"CVE-2021-44967","markdown":"https://insights.sbomify.com/CVE-2021-44967/index.md","name":"CVE-2021-44967","record":{"aliases":["BIT-limesurvey-2021-44967","GHSA-58c2-r57v-99r7"],"analysis":{"component_type":"web_application","fix_type":"no_fix_stated","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"LimeSurvey survey tool","requires_auth":"low_privilege","summary":"Remote attackers with superadmin privileges can upload arbitrary PHP files via the plugin installer, leading to remote code execution.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"limesurvey","vendor":"limesurvey"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"A Remote Code Execution (RCE) vulnerabilty exists in LimeSurvey 5.2.4 via the upload and install plugins function, which could let a remote malicious user upload an arbitrary PHP code file. NOTE: the Supplier's position is that plugins intentionally can contain arbitrary PHP code, and can only be installed by a superadmin, and therefore the security model is not violated by this finding.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2025-01-05","github_poc":3,"max_poc_stars":6,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-01-05T13:12:07Z","kind":"github_poc","ref":"https://github.com/D3Ext/CVE-2021-44967","stars":6,"title":"POC exploit for CVE-2021-44967"},{"date":"2025-02-17T04:55:23Z","kind":"github_poc","ref":"https://github.com/godylockz/CVE-2021-44967","stars":1,"title":"Proof of concept for CVE-2021-44967: LimeSurvey authenticated RCE"},{"date":"2025-04-18T10:59:15Z","kind":"github_poc","ref":"https://github.com/monke443/CVE-2021-44967","stars":1,"title":"Authenticated (privileged) remote command execution in LimeSurvey Version 5.2.4 via upload and install plugins allows a remote user to upload arbitrary PHP code file."}],"tier":"poc_unverified"},"has_fix":true,"headline":"File upload in n/a","id":"CVE-2021-44967","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"limesurvey:limesurvey","products":["limesurvey:limesurvey"],"type":"file_upload","year":"2021"},"n_packages":1,"n_references":3,"next":{"headline":"Use after free in n/a","id":"CVE-2021-44968"},"packages":[{"ecosystem":"Bitnami","fixed":["5.2.5"],"introduced":["5.2.4"],"last_affected":[],"package":"limesurvey","purl":"pkg:bitnami/limesurvey","source":"BIT-limesurvey-2021-44967"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2021-44966"},"products":["n/a"],"published":"2022-02-22","related":[{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2025-56422","kev_date_added":null,"published":"2026-03-10"},{"cvss_score":9.8,"headline":"File upload in n/a","id":"CVE-2022-48008","kev_date_added":null,"published":"2023-01-27"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2019-25019","kev_date_added":null,"published":"2021-02-14"},{"cvss_score":9.8,"headline":"Path traversal in n/a","id":"CVE-2020-11455","kev_date_added":null,"published":"2020-04-01"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2019-16184","kev_date_added":null,"published":"2019-09-09"},{"cvss_score":9.8,"headline":"Path traversal in n/a","id":"CVE-2019-9960","kev_date_added":null,"published":"2019-03-24"},{"cvss_score":9.8,"headline":"TCPDF vulnerable to attackers triggering deserialization of arbitrary data","id":"CVE-2018-17057","kev_date_added":null,"published":"2018-09-14"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-02-20","vendors":["n/a"]},"summary":"Remote attackers with superadmin privileges can upload arbitrary PHP files via the plugin installer, leading to remote code execution.","url":"https://insights.sbomify.com/CVE-2021-44967/"}