CVE-2021-45038 Information disclosure in n/a
Attackers can view private wiki contents by exploiting the rollback action, requiring administrators to upgrade MediaWiki.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-45038?
CVE-2021-45038 is a medium-severity vulnerability in Mediawiki Mediawiki, published on 17 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in MediaWiki before 1.35.5, 1.36.x before 1.36.3, and 1.37.x before 1.37.1. By using an action=rollback query, attackers can view private wiki contents.
Weakness: CWE-200
Which versions are affected by CVE-2021-45038?
1 open source package ship an affected version, including mediawiki. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki Bitnami | All versions | 1.35.5, 1.36.3, 1.37.1 |
Products include Mediawiki Mediawiki.
How do I fix CVE-2021-45038?
Upgrade mediawiki to a fixed version for your release line: 1.35.5, 1.36.3 or 1.37.1.
Is CVE-2021-45038 being exploited?
There is no known exploitation of CVE-2021-45038 in the wild and no public exploit code.
Other vulnerabilities in Mediawiki Mediawiki
Sources
Also known as BIT-mediawiki-2021-45038, DEBIAN-CVE-2021-45038, GHSA-8rcg-5g7w-gw95.