CVE-2021-45042 Denial of service in n/a

Medium 4.9 Published Updated

Authenticated users with write permissions can cause a panic and denial of service in HashiCorp Vault clusters using Integrated Storage.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-45042?

CVE-2021-45042 is a medium-severity denial of service vulnerability in Hashicorp Vault, published on 17 Dec 2021. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

In HashiCorp Vault and Vault Enterprise before 1.7.7, 1.8.x before 1.8.6, and 1.9.x before 1.9.1, clusters using the Integrated Storage backend allowed an authenticated user (with write permissions to a kv secrets engine) to cause a panic and denial of service of the storage backend. The earliest affected version is 1.4.0.

Which versions are affected by CVE-2021-45042?

1 open source package ship an affected version, including vault. It affects 1 product.

PackageAffectedFixed in
vault BitnamiFrom 1.4.01.7.7, 1.8.6, 1.9.1

Products include Hashicorp Vault.

How do I fix CVE-2021-45042?

Upgrade vault to a fixed version for your release line: 1.7.7, 1.8.6 or 1.9.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2021-45042 being exploited?

There is no known exploitation of CVE-2021-45042 in the wild and no public exploit code.

All Hashicorp Vault vulnerabilities

Sources

Also known as BIT-vault-2021-45042, GHSA-cr6r-4g38-f69g.

Is CVE-2021-45042 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free