# CVE-2021-45042: Denial of service in n/a

> Authenticated users with write permissions can cause a panic and denial of service in HashiCorp Vault clusters using Integrated Storage.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-vault-2021-45042, GHSA-cr6r-4g38-f69g

## What is CVE-2021-45042?

CVE-2021-45042 is a medium-severity denial of service vulnerability in Hashicorp Vault, published on 17 Dec 2021. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

In HashiCorp Vault and Vault Enterprise before 1.7.7, 1.8.x before 1.8.6, and 1.9.x before 1.9.1, clusters using the Integrated Storage backend allowed an authenticated user (with write permissions to a kv secrets engine) to cause a panic and denial of service of the storage backend. The earliest affected version is 1.4.0.

## Which versions are affected by CVE-2021-45042?

1 open source package ship an affected version, including vault. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vault` | Bitnami | From 1.4.0 | 1.7.7, 1.8.6, 1.9.1 |

Products: Hashicorp Vault.

## How do I fix CVE-2021-45042?

Upgrade vault to a fixed version for your release line: 1.7.7, 1.8.6 or 1.9.1.

## Is CVE-2021-45042 being exploited?

There is no known exploitation of CVE-2021-45042 in the wild and no public exploit code.

## Other vulnerabilities in Hashicorp Vault

- [CVE-2020-35192](https://insights.sbomify.com/CVE-2020-35192/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-12757](https://insights.sbomify.com/CVE-2020-12757/): Improper Input Validation in HashiCorp Vault (critical 9.8)
- [CVE-2025-6000](https://insights.sbomify.com/CVE-2025-6000/): Arbitrary Remote Code Execution via Plugin Catalog Abuse (critical 9.1)
- [CVE-2022-40186](https://insights.sbomify.com/CVE-2022-40186/): HashiCorp Vault vulnerable to incorrect metadata access (critical 9.1)
- [CVE-2022-36129](https://insights.sbomify.com/CVE-2022-36129/): Missing authorization in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-45042 and fix it if it is affected.

What it is: CVE-2021-45042 is a medium-severity denial of service vulnerability in Hashicorp Vault, published on 17 Dec 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-45042 in the wild and no public exploit code.

Affected packages and fixed versions:
- vault (Bitnami): affected from 1.4.0; fixed in 1.7.7, 1.8.6, 1.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-45042/ (Markdown: https://insights.sbomify.com/CVE-2021-45042/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-45042
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-45042
- OSV: https://osv.dev/vulnerability/CVE-2021-45042

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-45042/
Summaries are generated and may contain mistakes; the official description above is the record.
