{"answers":{"affected":"3 open source packages ship an affected version, including cobbler. It affects 5 products.","exploited":"There is no known exploitation of CVE-2021-45082 in the wild and no public exploit code.","fix":"Upgrade cobbler to 3.3.1 or later.","what":"CVE-2021-45082 is a high-severity vulnerability in Fedoraproject Fedora, published on 18 Feb 2022."},"fix_prompt":"Check this codebase for CVE-2021-45082 and fix it if it is affected.\n\nWhat it is: CVE-2021-45082 is a high-severity vulnerability in Fedoraproject Fedora, published on 18 Feb 2022. \nExploitation: There is no known exploitation of CVE-2021-45082 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cobbler (PyPI): affected all versions; fixed in 3.3.1\n- cobbler (PyPI): affected all versions; fixed in 3.3.1\n- cobbler (PyPI): affected all versions; fixed in 3.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-45082/ (Markdown: https://insights.sbomify.com/CVE-2021-45082/index.md)","id":"CVE-2021-45082","markdown":"https://insights.sbomify.com/CVE-2021-45082/index.md","name":"CVE-2021-45082","record":{"aliases":["GHSA-6cm4-gm85-972c","PYSEC-2022-37","UBUNTU-CVE-2021-45082","openSUSE-SU-2024:11853-1"],"analysis":null,"analysis_generated_by":null,"assigner":"mitre","cpe":[{"product":"cobbler","vendor":"cobbler_project"},{"product":"fedora","vendor":"fedoraproject"},{"product":"backports","vendor":"opensuse"},{"product":"factory","vendor":"opensuse"},{"product":"linux_enterprise_server","vendor":"suse"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"An issue was discovered in Cobbler before 3.3.1. In the templar.py file, the function check_for_invalid_imports can allow Cheetah code to import Python modules via the \"#from MODULE import\" substring. (Only lines beginning with #import are blocked.)","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command Injection in Cobbler","id":"CVE-2021-45082","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora","opensuse:backports","suse:linux_enterprise_server"],"type":null,"year":"2021"},"n_packages":4,"n_references":5,"next":{"headline":"Incorrect Default Permissions in Cobbler","id":"CVE-2021-45083"},"packages":[{"ecosystem":"PyPI","fixed":["3.3.1"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":null,"source":"GHSA-6cm4-gm85-972c"},{"ecosystem":"PyPI","fixed":["3.3.1"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"GHSA-6cm4-gm85-972c"},{"ecosystem":"PyPI","fixed":["3.3.1"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"PYSEC-2022-37"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.3.1.0+git.f5b0599a-1.1"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:rpm/opensuse/cobbler\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11853-1"}],"prev":{"headline":"Weak cryptography in n/a","id":"CVE-2021-45081"},"products":["n/a"],"published":"2022-02-18","related":[{"cvss_score":9.8,"headline":"Cobbler before 3.3.0 allows log poisoning","id":"CVE-2021-40323","kev_date_added":null,"published":"2021-10-04"},{"cvss_score":9.8,"headline":"Cobbler has Exposed Dangerous Method or Function","id":"CVE-2018-10931","kev_date_added":null,"published":"2018-08-09"},{"cvss_score":9.8,"headline":"Cobbler vulnerable to arbitrary code execution","id":"CVE-2017-1000469","kev_date_added":null,"published":"2018-01-03"},{"cvss_score":8.2,"headline":"Improper Authorization in cobbler/cobbler","id":"CVE-2022-0860","kev_date_added":null,"published":"2022-03-11"},{"cvss_score":7.5,"headline":"Cobbler before 3.3.0 allows arbitrary file write operations via upload_log_data.","id":"CVE-2021-40324","kev_date_added":null,"published":"2021-10-04"},{"cvss_score":7.5,"headline":"Cobbler before 3.3.0 allows authorization bypass for modification of settings.","id":"CVE-2021-40325","kev_date_added":null,"published":"2021-10-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2021-45082/"}