# CVE-2021-45082: Command Injection in Cobbler


- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 18 Feb 2022
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-6cm4-gm85-972c, PYSEC-2022-37, UBUNTU-CVE-2021-45082, openSUSE-SU-2024:11853-1

## What is CVE-2021-45082?

CVE-2021-45082 is a high-severity vulnerability in Fedoraproject Fedora, published on 18 Feb 2022. 

### Official description

An issue was discovered in Cobbler before 3.3.1. In the templar.py file, the function check_for_invalid_imports can allow Cheetah code to import Python modules via the "#from MODULE import" substring. (Only lines beginning with #import are blocked.)

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2021-45082?

3 open source packages ship an affected version, including cobbler. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cobbler` | PyPI | All versions | 3.3.1 |
| `cobbler` | PyPI | All versions | 3.3.1 |
| `cobbler` | PyPI | All versions | 3.3.1 |
| `cobbler` | openSUSE:Tumbleweed | All versions | 3.3.1.0+git.f5b0599a-1.1 |

Products: Cobbler Project Cobbler, Fedoraproject Fedora, Opensuse Backports, Opensuse Factory, Suse Linux Enterprise Server.

## How do I fix CVE-2021-45082?

Upgrade cobbler to 3.3.1 or later.

## Is CVE-2021-45082 being exploited?

There is no known exploitation of CVE-2021-45082 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2021-40323](https://insights.sbomify.com/CVE-2021-40323/): Cobbler before 3.3.0 allows log poisoning (critical 9.8)
- [CVE-2018-10931](https://insights.sbomify.com/CVE-2018-10931/): Cobbler has Exposed Dangerous Method or Function (critical 9.8)
- [CVE-2017-1000469](https://insights.sbomify.com/CVE-2017-1000469/): Cobbler vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2022-0860](https://insights.sbomify.com/CVE-2022-0860/): Improper Authorization in cobbler/cobbler (high 8.2)
- [CVE-2021-40324](https://insights.sbomify.com/CVE-2021-40324/): Cobbler before 3.3.0 allows arbitrary file write operations via upload_log_data. (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-45082 and fix it if it is affected.

What it is: CVE-2021-45082 is a high-severity vulnerability in Fedoraproject Fedora, published on 18 Feb 2022. 
Exploitation: There is no known exploitation of CVE-2021-45082 in the wild and no public exploit code.

Affected packages and fixed versions:
- cobbler (PyPI): affected all versions; fixed in 3.3.1
- cobbler (PyPI): affected all versions; fixed in 3.3.1
- cobbler (PyPI): affected all versions; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-45082/ (Markdown: https://insights.sbomify.com/CVE-2021-45082/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-45082
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-45082
- OSV: https://osv.dev/vulnerability/CVE-2021-45082

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-45082/
Summaries are generated and may contain mistakes; the official description above is the record.
