# CVE-2021-45083: Incorrect Default Permissions in Cobbler

> Local attackers can read world-readable configuration files to obtain sensitive user password hashes and secrets.

- **Severity:** High 7.1 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2022
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-5946-mpw5-pqxx, PYSEC-2022-38, SUSE-FU-2022:0750-1, SUSE-SU-2022:0507-1, SUSE-SU-2022:14891-1, UBUNTU-CVE-2021-45083

## What is CVE-2021-45083?

CVE-2021-45083 is a high-severity vulnerability in Fedoraproject Fedora, published on 20 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in Cobbler before 3.3.1. Files in /etc/cobbler are world readable. Two of those files contain some sensitive information that can be exposed to a local user who has non-privileged access to the server. The users.digest file contains the sha2-512 digest of users in a Cobbler local installation. In the case of an easy-to-guess password, it's trivial to obtain the plaintext string. The settings.yaml file contains secrets such as the hashed default password.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2021-45083?

3 open source packages ship an affected version, including cobbler. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cobbler` | PyPI | All versions | 3.3.1 |
| `cobbler` | PyPI | All versions | 3.3.1 |
| `cobbler` | PyPI | All versions | 3.3.1 |
| `cobbler` | SUSE:HPE Helion OpenStack 8 | All versions | 2.6.6-49.35.1 |
| `cobbler` | SUSE:Linux Enterprise Server 11 SP3-CLIENT-TOOLS | All versions | 2.2.2-0.68.15.1 |
| `cobbler` | SUSE:Linux Enterprise Server 11 SP4-CLIENT-TOOLS | All versions | 2.2.2-0.68.15.1 |
| `cobbler` | SUSE:Manager Client Tools 12 | All versions | 2.6.6-49.35.1 |
| `cobbler` | SUSE:OpenStack Cloud 8 | All versions | 2.6.6-49.35.1 |
| `cobbler` | SUSE:OpenStack Cloud 9 | All versions | 2.6.6-49.35.1 |

Products: Cobbler Project Cobbler, Fedoraproject Fedora.

## How do I fix CVE-2021-45083?

Upgrade cobbler to 3.3.1 or later.

## Is CVE-2021-45083 being exploited?

There is no known exploitation of CVE-2021-45083 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2021-40323](https://insights.sbomify.com/CVE-2021-40323/): Cobbler before 3.3.0 allows log poisoning (critical 9.8)
- [CVE-2018-10931](https://insights.sbomify.com/CVE-2018-10931/): Cobbler has Exposed Dangerous Method or Function (critical 9.8)
- [CVE-2017-1000469](https://insights.sbomify.com/CVE-2017-1000469/): Cobbler vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2022-0860](https://insights.sbomify.com/CVE-2022-0860/): Improper Authorization in cobbler/cobbler (high 8.2)
- [CVE-2021-45082](https://insights.sbomify.com/CVE-2021-45082/): Command Injection in Cobbler (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-45083 and fix it if it is affected.

What it is: CVE-2021-45083 is a high-severity vulnerability in Fedoraproject Fedora, published on 20 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-45083 in the wild and no public exploit code.

Affected packages and fixed versions:
- cobbler (PyPI): affected all versions; fixed in 3.3.1
- cobbler (PyPI): affected all versions; fixed in 3.3.1
- cobbler (PyPI): affected all versions; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-45083/ (Markdown: https://insights.sbomify.com/CVE-2021-45083/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-45083
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-45083
- OSV: https://osv.dev/vulnerability/CVE-2021-45083

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-45083/
Summaries are generated and may contain mistakes; the official description above is the record.
