# CVE-2021-45116: Information disclosure in Django

> Attackers can exploit the dictsort template filter to disclose sensitive information or trigger unintended method calls, potentially leading to code execution.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jan 2022
- **Updated:** 22 May 2025
- **Also known as:** BIT-django-2021-45116, DEBIAN-CVE-2021-45116, GHSA-8c5j-9r9f-c6w8, PYSEC-2022-2, UBUNTU-CVE-2021-45116

## What is CVE-2021-45116?

CVE-2021-45116 is a high-severity vulnerability in Djangoproject Django, published on 4 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Django 2.2 before 2.2.26, 3.2 before 3.2.11, and 4.0 before 4.0.1. Due to leveraging the Django Template Language's variable resolution logic, the dictsort template filter was potentially vulnerable to information disclosure, or an unintended method call, if passed a suitably crafted key.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-45116?

8 open source packages ship an affected version, including django and Django. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 2.2.0 | 2.2.26, 3.2.11, 4.0.1 |
| `django` | PyPI | From 2.2 | 2.2.26, 3.2.11, 4.0.1 |
| `django` | PyPI | From 2.2 | 2.2.26 |
| `django` | PyPI | From 3.2 | 3.2.11 |
| `django` | PyPI | From 4.0 | 4.0.1 |
| `Django` | PyPI | From 2.2 | 2.2.26 |
| `Django` | PyPI | From 3.2 | 3.2.11 |
| `Django` | PyPI | From 4.0 | 4.0.1 |

Products: Djangoproject Django, Fedoraproject Fedora.

## How do I fix CVE-2021-45116?

Upgrade django to a fixed version for your release line: 2.2.26, 3.2.11 or 4.0.1.

## Is CVE-2021-45116 being exploited?

There is no known exploitation of CVE-2021-45116 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-45116 and fix it if it is affected.

What it is: CVE-2021-45116 is a high-severity vulnerability in Djangoproject Django, published on 4 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-45116 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 2.2.0; fixed in 2.2.26, 3.2.11, 4.0.1
- django (PyPI): affected from 2.2; fixed in 2.2.26, 3.2.11, 4.0.1
- django (PyPI): affected from 2.2; fixed in 2.2.26
- django (PyPI): affected from 3.2; fixed in 3.2.11
- django (PyPI): affected from 4.0; fixed in 4.0.1
- Django (PyPI): affected from 2.2; fixed in 2.2.26
- Django (PyPI): affected from 3.2; fixed in 3.2.11
- Django (PyPI): affected from 4.0; fixed in 4.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-45116/ (Markdown: https://insights.sbomify.com/CVE-2021-45116/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-45116
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-45116
- OSV: https://osv.dev/vulnerability/CVE-2021-45116

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-45116/
Summaries are generated and may contain mistakes; the official description above is the record.
