# CVE-2021-45419: Other in n/a

> Improper input validation in Starcharge EV charging cabinets allows potential manipulation of device behavior, requiring firmware updates.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 22 Dec 2021
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-hw3c-cw6g-7h26

## What is CVE-2021-45419?

CVE-2021-45419 is a high-severity vulnerability in n/a, published on 22 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Certain Starcharge products are affected by Improper Input Validation. The affected products include: Nova 360 Cabinet <= 1.3.0.0.7b102 - Fixed: Beta1.3.0.1.0 and Titan 180 Premium <= 1.3.0.0.6 - Fixed: 1.3.0.0.9.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2021-45419?

It affects 2 products.


Products: Starcharge Nova 360 Cabinet Firmware, Starcharge Titan 180 Premium Firmware.

## How do I fix CVE-2021-45419?

No fix has been published for CVE-2021-45419 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-45419 being exploited?

There is no known exploitation of CVE-2021-45419 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-45418](https://insights.sbomify.com/CVE-2021-45418/): Path traversal in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-45419 and fix it if it is affected.

What it is: CVE-2021-45419 is a high-severity vulnerability in n/a, published on 22 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-45419 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-45419/ (Markdown: https://insights.sbomify.com/CVE-2021-45419/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-45419
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-45419
- OSV: https://osv.dev/vulnerability/CVE-2021-45419

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-45419/
Summaries are generated and may contain mistakes; the official description above is the record.
