# CVE-2021-45457: Overly broad CORS configuration

> Attackers can exploit overly broad CORS settings to send credentialed cross-origin requests, potentially bypassing security controls and accessing sensitive data.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jan 2022
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-mgpf-hhgf-cxg4

## What is CVE-2021-45457?

CVE-2021-45457 is a high-severity vulnerability in Apache Kylin, published on 6 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Kylin, Cross-origin requests with credentials are allowed to be sent from any origin. This issue affects Apache Kylin 2 version 2.6.6 and prior versions; Apache Kylin 3 version 3.1.2 and prior versions; Apache Kylin 4 version 4.0.0 and prior versions.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2021-45457?

4 open source packages ship an affected version, including org.apache.kylin:kylin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.kylin:kylin` | Maven | All versions | 3.1.3 |
| `org.apache.kylin:kylin` | Maven | All versions | 3.1.3 |
| `org.apache.kylin:kylin` | Maven | From 4.0.0 | 4.0.1 |
| `org.apache.kylin:kylin` | Maven | From 4.0.0 | 4.0.1 |

Products: Apache Kylin.

## How do I fix CVE-2021-45457?

Upgrade org.apache.kylin:kylin to a fixed version for your release line: 3.1.3 or 4.0.1.

## Is CVE-2021-45457 being exploited?

There is no known exploitation of CVE-2021-45457 in the wild and no public exploit code.

## Other vulnerabilities in Apache Kylin

- [CVE-2020-1956](https://insights.sbomify.com/CVE-2020-1956/): Apache Kylin OS Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-62390](https://insights.sbomify.com/CVE-2026-62390/): Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API (critical 9.8)
- [CVE-2022-44621](https://insights.sbomify.com/CVE-2022-44621/): Apache Kylin: Command injection by Diagnosis Controller (critical 9.8)
- [CVE-2022-24697](https://insights.sbomify.com/CVE-2022-24697/): Apache Kylin vulnerable to remote code execution (critical 9.8)
- [CVE-2021-31522](https://insights.sbomify.com/CVE-2021-31522/): Apache Kylin unsafe class loading (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-45457 and fix it if it is affected.

What it is: CVE-2021-45457 is a high-severity vulnerability in Apache Kylin, published on 6 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-45457 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.kylin:kylin (Maven): affected all versions; fixed in 3.1.3
- org.apache.kylin:kylin (Maven): affected all versions; fixed in 3.1.3
- org.apache.kylin:kylin (Maven): affected from 4.0.0; fixed in 4.0.1
- org.apache.kylin:kylin (Maven): affected from 4.0.0; fixed in 4.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-45457/ (Markdown: https://insights.sbomify.com/CVE-2021-45457/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-45457
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-45457
- OSV: https://osv.dev/vulnerability/CVE-2021-45457

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-45457/
Summaries are generated and may contain mistakes; the official description above is the record.
