CVE-2021-45458 Hardcoded credentials
Attackers can decrypt passwords encrypted with the default hardcoded key in Apache Kylin's configuration, exposing sensitive credentials.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-45458?
CVE-2021-45458 is a high-severity vulnerability in Apache Kylin, published on 6 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Kylin provides encryption classes PasswordPlaceholderConfigurer to help users encrypt their passwords. In the encryption algorithm used by this encryption class, the cipher is initialized with a hardcoded key and IV. If users use class PasswordPlaceholderConfigurer to encrypt their password and configure it into kylin's configuration file, there is a risk that the password may be decrypted. This issue affects Apache Kylin 2 version 2.6.6 and prior versions; Apache Kylin 3 version 3.1.2 and prior versions; Apache Kylin 4 version 4.0.0 and prior versions.
Which versions are affected by CVE-2021-45458?
4 open source packages ship an affected version, including org.apache.kylin:kylin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.kylin:kylin Maven | All versions | 3.1.3 |
org.apache.kylin:kylin Maven | All versions | 3.1.3 |
org.apache.kylin:kylin Maven | From 4.0.0 | 4.0.1 |
org.apache.kylin:kylin Maven | From 4.0.0 | 4.0.1 |
Products include Apache Kylin.
How do I fix CVE-2021-45458?
Upgrade org.apache.kylin:kylin to a fixed version for your release line: 3.1.3 or 4.0.1.
Is CVE-2021-45458 being exploited?
There is no known exploitation of CVE-2021-45458 in the wild and no public exploit code.
Other vulnerabilities in Apache Kylin
- CVE-2020-1956 Apache Kylin OS Command Injection
- CVE-2026-62390 Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API
- CVE-2022-44621 Apache Kylin: Command injection by Diagnosis Controller
- CVE-2022-24697 Apache Kylin vulnerable to remote code execution
- CVE-2021-31522 Apache Kylin unsafe class loading
Sources
Also known as GHSA-9fj5-jg6f-qg5r.