{"answers":{"affected":"5 open source packages ship an affected version, including vec-const. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-45680 in the wild and no public exploit code.","fix":"Upgrade vec-const to 2.0.0 or later.","what":"CVE-2021-45680 is a high-severity memory corruption vulnerability in n/a, published on 26 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-45680 and fix it if it is affected.\n\nWhat it is: CVE-2021-45680 is a high-severity memory corruption vulnerability in n/a, published on 26 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-45680 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vec-const (crates.io): affected all versions; fixed in 2.0.0\n- vec-const (crates.io): affected all versions; fixed in 2.0.0\n- vec-const (crates.io): affected all versions; fixed in 2.0.0\n- vec-const (crates.io): affected all versions; fixed in 2.0.0\n- vec-const (crates.io): affected from 0.0.0-0; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-45680/ (Markdown: https://insights.sbomify.com/CVE-2021-45680/index.md)","id":"CVE-2021-45680","markdown":"https://insights.sbomify.com/CVE-2021-45680/index.md","name":"CVE-2021-45680","record":{"aliases":["GHSA-jmwx-r3gq-qq3p","GHSA-x76r-966h-5qv9","RUSTSEC-2021-0082"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust vec-const crate","requires_auth":"none","summary":"A memory corruption vulnerability in the Rust vec-const crate allows attackers to potentially execute arbitrary code or cause denial of service.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"vec-const","vendor":"vec-const_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"An issue was discovered in the vec-const crate before 2.0.0 for Rust. It tries to construct a Vec from a pointer to a const slice, leading to memory corruption.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"vec-const attempts to construct a Vec from a pointer to a const slice","id":"CVE-2021-45680","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"memory_corruption","year":"2021"},"n_packages":5,"n_references":2,"next":{"headline":"QueryInterface should call AddRef before returning pointer","id":"CVE-2021-45681"},"packages":[{"ecosystem":"crates.io","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"vec-const","purl":null,"source":"GHSA-jmwx-r3gq-qq3p"},{"ecosystem":"crates.io","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"vec-const","purl":"pkg:cargo/vec-const","source":"GHSA-jmwx-r3gq-qq3p"},{"ecosystem":"crates.io","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"vec-const","purl":null,"source":"GHSA-x76r-966h-5qv9"},{"ecosystem":"crates.io","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"vec-const","purl":"pkg:cargo/vec-const","source":"GHSA-x76r-966h-5qv9"},{"ecosystem":"crates.io","fixed":["2.0.0"],"introduced":["0.0.0-0"],"last_affected":[],"package":"vec-const","purl":"pkg:cargo/vec-const","source":"RUSTSEC-2021-0082"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2021-45679"},"products":["n/a"],"published":"2021-12-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"A memory corruption vulnerability in the Rust vec-const crate allows attackers to potentially execute arbitrary code or cause denial of service.","url":"https://insights.sbomify.com/CVE-2021-45680/"}