# CVE-2021-45681: QueryInterface should call AddRef before returning pointer

> Attackers can trigger memory corruption in the derive-com-impl Rust crate due to missing AddRef calls, potentially leading to code execution or crashes.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-9rg7-3j4f-cf4x, GHSA-w4cc-pc2h-whcj, RUSTSEC-2021-0083

## What is CVE-2021-45681?

CVE-2021-45681 is a high-severity memory corruption vulnerability in n/a, published on 26 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the derive-com-impl crate before 0.1.2 for Rust. An invalid reference (and memory corruption) can occur because AddRef might not be called before returning a pointer.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2021-45681?

5 open source packages ship an affected version, including derive-com-impl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `derive-com-impl` | crates.io | All versions | None |
| `derive-com-impl` | crates.io | All versions | None |
| `derive-com-impl` | crates.io | All versions | 0.1.2 |
| `derive-com-impl` | crates.io | All versions | 0.1.2 |
| `derive-com-impl` | crates.io | From 0.0.0-0 | 0.1.2 |

Products: Derive-Com-Impl Project Derive-Com-Impl.

## How do I fix CVE-2021-45681?

Upgrade derive-com-impl to 0.1.2 or later.

## Is CVE-2021-45681 being exploited?

There is no known exploitation of CVE-2021-45681 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-45681 and fix it if it is affected.

What it is: CVE-2021-45681 is a high-severity memory corruption vulnerability in n/a, published on 26 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-45681 in the wild and no public exploit code.

Affected packages and fixed versions:
- derive-com-impl (crates.io): affected all versions; no fix listed
- derive-com-impl (crates.io): affected all versions; no fix listed
- derive-com-impl (crates.io): affected all versions; fixed in 0.1.2
- derive-com-impl (crates.io): affected all versions; fixed in 0.1.2
- derive-com-impl (crates.io): affected from 0.0.0-0; fixed in 0.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-45681/ (Markdown: https://insights.sbomify.com/CVE-2021-45681/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-45681
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-45681
- OSV: https://osv.dev/vulnerability/CVE-2021-45681

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-45681/
Summaries are generated and may contain mistakes; the official description above is the record.
