# CVE-2021-45700: Process crashes when the cell used as DepGroup is not alive

> Attackers can crash the Nervos CKB blockchain node by submitting a dead call as a DepGroup, requiring an upgrade of the ckb crate.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-45p7-c959-rgcm, GHSA-cw98-cx2m-9qqg, RUSTSEC-2021-0109

## What is CVE-2021-45700?

CVE-2021-45700 is a high-severity denial of service vulnerability in n/a, published on 26 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the ckb crate before 0.40.0 for Rust. Attackers can cause a denial of service (Nervos CKB blockchain node crash) via a dead call that is used as a DepGroup.

## Which versions are affected by CVE-2021-45700?

5 open source packages ship an affected version, including ckb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ckb` | crates.io | All versions | 0.40.0 |
| `ckb` | crates.io | All versions | 0.40.0 |
| `ckb` | crates.io | All versions | 0.40.0 |
| `ckb` | crates.io | All versions | 0.40.0 |
| `ckb` | crates.io | From 0.0.0-0 | 0.40.0 |

Products: Nervos Ckb.

## How do I fix CVE-2021-45700?

Upgrade ckb to 0.40.0 or later.

## Is CVE-2021-45700 being exploited?

There is no known exploitation of CVE-2021-45700 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-45698](https://insights.sbomify.com/CVE-2021-45698/): RPC call failure in ckb (critical 9.8)
- [CVE-2021-45699](https://insights.sbomify.com/CVE-2021-45699/): Allocation of Resources Without Limits or Throttling in ckb (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-45700 and fix it if it is affected.

What it is: CVE-2021-45700 is a high-severity denial of service vulnerability in n/a, published on 26 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-45700 in the wild and no public exploit code.

Affected packages and fixed versions:
- ckb (crates.io): affected all versions; fixed in 0.40.0
- ckb (crates.io): affected all versions; fixed in 0.40.0
- ckb (crates.io): affected all versions; fixed in 0.40.0
- ckb (crates.io): affected all versions; fixed in 0.40.0
- ckb (crates.io): affected from 0.0.0-0; fixed in 0.40.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-45700/ (Markdown: https://insights.sbomify.com/CVE-2021-45700/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-45700
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-45700
- OSV: https://osv.dev/vulnerability/CVE-2021-45700

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-45700/
Summaries are generated and may contain mistakes; the official description above is the record.
