# CVE-2021-45702: Use After Free in tremor-script

> A use-after-free vulnerability in the tremor-script Rust library allows attackers to potentially execute arbitrary code or cause a denial of service via a merge operation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-9qvw-46gf-4fv8

## What is CVE-2021-45702?

CVE-2021-45702 is a high-severity use after free vulnerability in n/a, published on 26 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the tremor-script crate before 0.11.6 for Rust. A merge operation may result in a use-after-free.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2021-45702?

2 open source packages ship an affected version, including tremor-script. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tremor-script` | crates.io | From 0.7.2 | 0.11.6 |
| `tremor-script` | crates.io | From 0.7.2 | 0.11.6 |

Products: Linuxfoundation Tremor-Script.

## How do I fix CVE-2021-45702?

Upgrade tremor-script to 0.11.6 or later.

## Is CVE-2021-45702 being exploited?

There is no known exploitation of CVE-2021-45702 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-45701](https://insights.sbomify.com/CVE-2021-45701/): Use After Free in tremor-script (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-45702 and fix it if it is affected.

What it is: CVE-2021-45702 is a high-severity use after free vulnerability in n/a, published on 26 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-45702 in the wild and no public exploit code.

Affected packages and fixed versions:
- tremor-script (crates.io): affected from 0.7.2; fixed in 0.11.6
- tremor-script (crates.io): affected from 0.7.2; fixed in 0.11.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-45702/ (Markdown: https://insights.sbomify.com/CVE-2021-45702/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-45702
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-45702
- OSV: https://osv.dev/vulnerability/CVE-2021-45702

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-45702/
Summaries are generated and may contain mistakes; the official description above is the record.
