# CVE-2021-45704: AtomicBucket<T> unconditionally implements Send/Sync

> A data race in the metrics-util crate allows memory corruption, potentially leading to code execution or denial of service.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-3hxh-7jxm-59x4, GHSA-cwvc-87xq-pc5m, RUSTSEC-2021-0113

## What is CVE-2021-45704?

CVE-2021-45704 is a high-severity vulnerability in n/a, published on 26 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the metrics-util crate before 0.7.0 for Rust. There is a data race and memory corruption because AtomicBucket<T> unconditionally implements the Send and Sync traits.

Weakness: CWE-787 (Out-of-bounds Write), CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2021-45704?

5 open source packages ship an affected version, including metrics-util. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `metrics-util` | crates.io | All versions | 0.7.0 |
| `metrics-util` | crates.io | All versions | 0.7.0 |
| `metrics-util` | crates.io | All versions | 0.7.0 |
| `metrics-util` | crates.io | All versions | 0.7.0 |
| `metrics-util` | crates.io | From 0.0.0-0 | 0.7.0 |

Products: Metrics-Util Project Metrics-Util.

## How do I fix CVE-2021-45704?

Upgrade metrics-util to 0.7.0 or later.

## Is CVE-2021-45704 being exploited?

There is no known exploitation of CVE-2021-45704 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-45704 and fix it if it is affected.

What it is: CVE-2021-45704 is a high-severity vulnerability in n/a, published on 26 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-45704 in the wild and no public exploit code.

Affected packages and fixed versions:
- metrics-util (crates.io): affected all versions; fixed in 0.7.0
- metrics-util (crates.io): affected all versions; fixed in 0.7.0
- metrics-util (crates.io): affected all versions; fixed in 0.7.0
- metrics-util (crates.io): affected all versions; fixed in 0.7.0
- metrics-util (crates.io): affected from 0.0.0-0; fixed in 0.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-45704/ (Markdown: https://insights.sbomify.com/CVE-2021-45704/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-45704
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-45704
- OSV: https://osv.dev/vulnerability/CVE-2021-45704

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-45704/
Summaries are generated and may contain mistakes; the official description above is the record.
