# CVE-2021-45706: Memory flaw in zeroize_derive

> Attackers can read sensitive data from memory because the zeroize_derive crate fails to zero out dropped enum variants.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-c5hx-w945-j4pq, RUSTSEC-2021-0115

## What is CVE-2021-45706?

CVE-2021-45706 is a critical vulnerability in n/a, published on 26 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the zeroize_derive crate before 1.1.1 for Rust. Dropped memory is not zeroed out for an enum.

Weakness: CWE-459 (Incomplete Cleanup)

## Which versions are affected by CVE-2021-45706?

3 open source packages ship an affected version, including zeroize_derive. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zeroize_derive` | crates.io | All versions | 1.1.1 |
| `zeroize_derive` | crates.io | All versions | 1.1.1 |
| `zeroize_derive` | crates.io | From 0.0.0-0 | 1.1.1 |

Products: Zeroize Derive Project Zeroize Derive.

## How do I fix CVE-2021-45706?

Upgrade zeroize_derive to 1.1.1 or later.

## Is CVE-2021-45706 being exploited?

There is no known exploitation of CVE-2021-45706 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-45706 and fix it if it is affected.

What it is: CVE-2021-45706 is a critical vulnerability in n/a, published on 26 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-45706 in the wild and no public exploit code.

Affected packages and fixed versions:
- zeroize_derive (crates.io): affected all versions; fixed in 1.1.1
- zeroize_derive (crates.io): affected all versions; fixed in 1.1.1
- zeroize_derive (crates.io): affected from 0.0.0-0; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-45706/ (Markdown: https://insights.sbomify.com/CVE-2021-45706/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-45706
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-45706
- OSV: https://osv.dev/vulnerability/CVE-2021-45706

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-45706/
Summaries are generated and may contain mistakes; the official description above is the record.
