# CVE-2021-45707: Out-of-bounds Write in nix

> An out-of-bounds write in the nix crate allows attackers to cause memory corruption or denial of service when processing users with many groups.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-45707, GHSA-76w9-p8mg-j927, GHSA-wgrg-5h56-jg27, RUSTSEC-2021-0119, UBUNTU-CVE-2021-45707

## What is CVE-2021-45707?

CVE-2021-45707 is a critical memory corruption vulnerability in n/a, published on 26 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the nix crate 0.16.0 and later before 0.20.2, 0.21.x before 0.21.2, and 0.22.x before 0.22.2 for Rust. unistd::getgrouplist has an out-of-bounds write if a user is in more than 16 /etc/groups groups.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2021-45707?

13 open source packages ship an affected version, including nix. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nix` | crates.io | From 0.16.0 | 0.20.2, 0.21.2, 0.22.2, 0.23.0 |
| `nix` | crates.io | From 0.16.0 | 0.20.2 |
| `nix` | crates.io | From 0.16.0 | 0.20.2 |
| `nix` | crates.io | From 0.16.0 | 0.20.2 |
| `nix` | crates.io | From 0.16.0 | 0.20.2 |
| `nix` | crates.io | From 0.21.0 | 0.21.2 |
| `nix` | crates.io | From 0.21.0 | 0.21.2 |
| `nix` | crates.io | From 0.21.0 | 0.21.2 |
| `nix` | crates.io | From 0.21.0 | 0.21.2 |
| `nix` | crates.io | From 0.22.0 | 0.22.2 |
| `nix` | crates.io | From 0.22.0 | 0.22.2 |
| `nix` | crates.io | From 0.22.0 | 0.22.2 |
| `nix` | crates.io | From 0.22.0 | 0.22.2 |

Products: Nix Project Nix.

## How do I fix CVE-2021-45707?

Upgrade nix to a fixed version for your release line: 0.20.2, 0.21.2, 0.22.2 or 0.23.0.

## Is CVE-2021-45707 being exploited?

There is no known exploitation of CVE-2021-45707 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-45707 and fix it if it is affected.

What it is: CVE-2021-45707 is a critical memory corruption vulnerability in n/a, published on 26 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-45707 in the wild and no public exploit code.

Affected packages and fixed versions:
- nix (crates.io): affected from 0.16.0; fixed in 0.20.2, 0.21.2, 0.22.2, 0.23.0
- nix (crates.io): affected from 0.16.0; fixed in 0.20.2
- nix (crates.io): affected from 0.16.0; fixed in 0.20.2
- nix (crates.io): affected from 0.16.0; fixed in 0.20.2
- nix (crates.io): affected from 0.16.0; fixed in 0.20.2
- nix (crates.io): affected from 0.21.0; fixed in 0.21.2
- nix (crates.io): affected from 0.21.0; fixed in 0.21.2
- nix (crates.io): affected from 0.21.0; fixed in 0.21.2
- nix (crates.io): affected from 0.21.0; fixed in 0.21.2
- nix (crates.io): affected from 0.22.0; fixed in 0.22.2
- nix (crates.io): affected from 0.22.0; fixed in 0.22.2
- nix (crates.io): affected from 0.22.0; fixed in 0.22.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-45707/ (Markdown: https://insights.sbomify.com/CVE-2021-45707/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-45707
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-45707
- OSV: https://osv.dev/vulnerability/CVE-2021-45707

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-45707/
Summaries are generated and may contain mistakes; the official description above is the record.
