CVE-2021-45710 Race Condition in tokio

High 8.1 Published Updated

A data race in the tokio Rust library can lead to memory corruption, potentially allowing code execution or denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-45710?

CVE-2021-45710 is a high-severity vulnerability in n/a, published on 26 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue was discovered in the tokio crate before 1.8.4, and 1.9.x through 1.13.x before 1.13.1, for Rust. In certain circumstances involving a closed oneshot channel, there is a data race and memory corruption.

Weakness: CWE-362

Which versions are affected by CVE-2021-45710?

5 open source packages ship an affected version, including tokio. It affects 1 product.

PackageAffectedFixed in
tokio crates.ioFrom 0.1.141.8.4, 1.13.1
tokio crates.ioFrom 0.1.141.8.4
tokio crates.ioFrom 0.1.141.8.4
tokio crates.ioFrom 1.9.01.13.1
tokio crates.ioFrom 1.9.01.13.1
Linux distribution packages (11)
389-ds SUSE:Linux Enterprise Module for Server Applications 15 SP3All versions1.4.4.19~git59.136fc84-150300.3.27.1
389-ds SUSE:Linux Enterprise Module for Server Applications 15 SP4All versions2.0.16~git56.d15a0a7-150400.3.15.1
389-ds openSUSE:Leap 15.3All versions1.4.4.19~git59.136fc84-150300.3.27.1
389-ds openSUSE:Leap 15.4All versions2.0.16~git56.d15a0a7-150400.3.15.1
greetd openSUSE:TumbleweedAll versions0.8.0-2.1
rustscan openSUSE:TumbleweedAll versions2.0.1+0-1.1
rustup openSUSE:TumbleweedAll versions1.24.3~git1.0a74fef5-2.1
sccache openSUSE:TumbleweedAll versions0.2.15~git0.6b6d2f7-8.1
spotifyd openSUSE:TumbleweedAll versions0.3.3-2.1
tealdeer openSUSE:TumbleweedAll versions1.5.0+0-1.1
tuigreet openSUSE:TumbleweedAll versions0.7.1-3.1

Products include Tokio Tokio.

How do I fix CVE-2021-45710?

Upgrade tokio to a fixed version for your release line: 1.8.4 or 1.13.1.

Is CVE-2021-45710 being exploited?

There is no known exploitation of CVE-2021-45710 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2021-45710, GHSA-fg7r-2g4j-5cgr, RUSTSEC-2021-0124, SUSE-SU-2022:3996-1, SUSE-SU-2022:4124-1, UBUNTU-CVE-2021-45710 and 8 more.

Is CVE-2021-45710 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free