# CVE-2021-45712: RustEmbed generated `get` method allows for directory traversal when reading files from disk

> Attackers can read arbitrary files via directory traversal in debug mode of the rust-embed crate, requiring an upgrade to secure the application.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-cgw6-f3mj-h742, GHSA-xrg3-hmf3-rvgw, RUSTSEC-2021-0126

## What is CVE-2021-45712?

CVE-2021-45712 is a high-severity path traversal vulnerability in n/a, published on 26 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the rust-embed crate before 6.3.0 for Rust. A ../ directory traversal can sometimes occur in debug mode.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-45712?

5 open source packages ship an affected version, including rust-embed. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rust-embed` | crates.io | All versions | 6.3.0 |
| `rust-embed` | crates.io | All versions | 6.3.0 |
| `rust-embed` | crates.io | All versions | 6.3.0 |
| `rust-embed` | crates.io | All versions | 6.3.0 |
| `rust-embed` | crates.io | From 0.0.0-0 | 6.3.0 |

Products: Rust-Embed Project Rust-Embed.

## How do I fix CVE-2021-45712?

Upgrade rust-embed to 6.3.0 or later.

## Is CVE-2021-45712 being exploited?

There is no known exploitation of CVE-2021-45712 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-45712 and fix it if it is affected.

What it is: CVE-2021-45712 is a high-severity path traversal vulnerability in n/a, published on 26 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-45712 in the wild and no public exploit code.

Affected packages and fixed versions:
- rust-embed (crates.io): affected all versions; fixed in 6.3.0
- rust-embed (crates.io): affected all versions; fixed in 6.3.0
- rust-embed (crates.io): affected all versions; fixed in 6.3.0
- rust-embed (crates.io): affected all versions; fixed in 6.3.0
- rust-embed (crates.io): affected from 0.0.0-0; fixed in 6.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-45712/ (Markdown: https://insights.sbomify.com/CVE-2021-45712/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-45712
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-45712
- OSV: https://osv.dev/vulnerability/CVE-2021-45712

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-45712/
Summaries are generated and may contain mistakes; the official description above is the record.
