CVE-2021-45895 Cross-site Scripting in Netgen Tags Bundle
Cross-site scripting vulnerability in the Tags Admin interface allows attackers to execute arbitrary scripts in the context of other users.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-45895?
CVE-2021-45895 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 Dec 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Netgen Tags Bundle 3.4.x before 3.4.11 and 4.0.x before 4.0.15 allows XSS in the Tags Admin interface.
Weakness: CWE-79
Which versions are affected by CVE-2021-45895?
4 open source packages ship an affected version, including netgen/tagsbundle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
netgen/tagsbundle Packagist | From 3.4.0 | 3.4.11 |
netgen/tagsbundle Packagist | From 3.4.0 | 3.4.11 |
netgen/tagsbundle Packagist | From 4.0.0 | 4.0.15 |
netgen/tagsbundle Packagist | From 4.0.0 | 4.0.15 |
Products include Netgen Tags Bundle.
How do I fix CVE-2021-45895?
Upgrade netgen/tagsbundle to a fixed version for your release line: 3.4.11 or 4.0.15.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-45895 being exploited?
There is no known exploitation of CVE-2021-45895 in the wild and no public exploit code.
Sources
Also known as GHSA-xvvv-wj7j-r9jm.