# CVE-2021-45943: Memory corruption in n/a

> A heap-based buffer overflow in GDAL allows attackers to execute arbitrary code or cause denial of service via crafted PCIDSK files.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-gdal-2021-45943, DEBIAN-CVE-2021-45943, DSA-5239-1, GHSA-x54c-x29c-rpr5, MGASA-2022-0137, PYSEC-2022-43065, UBUNTU-CVE-2021-45943

## What is CVE-2021-45943?

CVE-2021-45943 is a medium-severity memory corruption vulnerability in Debian Debian Linux, published on 31 Dec 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

GDAL 3.3.0 through 3.4.0 has a heap-based buffer overflow in PCIDSK::CPCIDSKFile::ReadFromFile (called from PCIDSK::CPCIDSKSegment::ReadFromFile and PCIDSK::CPCIDSKBinarySegment::CPCIDSKBinarySegment).

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2021-45943?

2 open source packages ship an affected version, including gdal. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gdal` | Bitnami | From 3.3.0 | 3.4.1 |
| `gdal` | PyPI | From 3.3.0 | 3.4.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Oracle Spatial and Graph, Osgeo Gdal.

## How do I fix CVE-2021-45943?

Upgrade gdal to 3.4.1 or later.

## Is CVE-2021-45943 being exploited?

There is no known exploitation of CVE-2021-45943 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-45943 and fix it if it is affected.

What it is: CVE-2021-45943 is a medium-severity memory corruption vulnerability in Debian Debian Linux, published on 31 Dec 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-45943 in the wild and no public exploit code.

Affected packages and fixed versions:
- gdal (Bitnami): affected from 3.3.0; fixed in 3.4.1
- gdal (PyPI): affected from 3.3.0; fixed in 3.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-45943/ (Markdown: https://insights.sbomify.com/CVE-2021-45943/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-45943
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-45943
- OSV: https://osv.dev/vulnerability/CVE-2021-45943

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-45943/
Summaries are generated and may contain mistakes; the official description above is the record.
