CVE-2021-46146 Cross-site scripting in n/a

Medium 5.4 Published Updated

Cross-site scripting vulnerability in MediaWiki's WikibaseMediaInfo component allows attackers to inject malicious scripts via media file captions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-46146?

CVE-2021-46146 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 7 Jan 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue was discovered in MediaWiki before 1.35.5, 1.36.x before 1.36.3, and 1.37.x before 1.37.1. The WikibaseMediaInfo component is vulnerable to XSS via the caption fields for a given media file.

Weakness: CWE-79

Which versions are affected by CVE-2021-46146?

1 open source package ship an affected version, including mediawiki. It affects 1 product.

PackageAffectedFixed in
mediawiki BitnamiAll versions1.35.5, 1.36.3, 1.37.1

Products include Mediawiki Mediawiki.

How do I fix CVE-2021-46146?

Upgrade mediawiki to a fixed version for your release line: 1.35.5, 1.36.3 or 1.37.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-46146 being exploited?

There is no known exploitation of CVE-2021-46146 in the wild and no public exploit code.

All Mediawiki Mediawiki vulnerabilities

Sources

Also known as BIT-mediawiki-2021-46146, GHSA-v84x-p2pv-wp5c.

Is CVE-2021-46146 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free