CVE-2021-46147 Cross-site request forgery in n/a
Cross-site request forgery in the MassEditRegex extension allows attackers to perform unauthorized actions on behalf of authenticated users.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-46147?
CVE-2021-46147 is a high-severity vulnerability in Mediawiki Mediawiki, published on 7 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An issue was discovered in MediaWiki before 1.35.5, 1.36.x before 1.36.3, and 1.37.x before 1.37.1. MassEditRegex allows CSRF.
Weakness: CWE-352
Which versions are affected by CVE-2021-46147?
1 open source package ship an affected version, including mediawiki. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki Bitnami | All versions | 1.35.5, 1.36.3, 1.37.1 |
Products include Mediawiki Mediawiki.
How do I fix CVE-2021-46147?
Upgrade mediawiki to a fixed version for your release line: 1.35.5, 1.36.3 or 1.37.1.
Is CVE-2021-46147 being exploited?
There is no known exploitation of CVE-2021-46147 in the wild and no public exploit code.
Other vulnerabilities in Mediawiki Mediawiki
Sources
Also known as BIT-mediawiki-2021-46147, GHSA-m7x9-mpqf-4qc7.