CVE-2021-46148 Information disclosure in n/a
Unprivileged users can view confidential IP addresses and User-Agent headers on testwiki SecurePoll instances in MediaWiki.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-46148?
CVE-2021-46148 is a medium-severity vulnerability in Mediawiki Mediawiki, published on 7 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in MediaWiki before 1.35.5, 1.36.x before 1.36.3, and 1.37.x before 1.37.1. Some unprivileged users can view confidential information (e.g., IP addresses and User-Agent headers for election traffic) on a testwiki SecurePoll instance.
Weakness: CWE-200
Which versions are affected by CVE-2021-46148?
1 open source package ship an affected version, including mediawiki. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki Bitnami | All versions | 1.35.5, 1.36.3, 1.37.1 |
Products include Mediawiki Mediawiki.
How do I fix CVE-2021-46148?
Upgrade mediawiki to a fixed version for your release line: 1.35.5, 1.36.3 or 1.37.1.
Is CVE-2021-46148 being exploited?
There is no known exploitation of CVE-2021-46148 in the wild and no public exploit code.
Other vulnerabilities in Mediawiki Mediawiki
Sources
Also known as BIT-mediawiki-2021-46148, GHSA-5r66-qpvr-xfcc.