# CVE-2021-46149: Denial of service in n/a

> Attackers can cause denial of service by submitting very long search keys in MediaWiki's Language Name Search feature.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jan 2022
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-mediawiki-2021-46149, GHSA-6438-3865-mcg8

## What is CVE-2021-46149?

CVE-2021-46149 is a high-severity denial of service vulnerability in Mediawiki Mediawiki, published on 7 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in MediaWiki before 1.35.5, 1.36.x before 1.36.3, and 1.37.x before 1.37.1. A denial of service (resource consumption) can be accomplished by searching for a very long key in a Language Name Search.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-46149?

1 open source package ship an affected version, including mediawiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.35.5, 1.36.3, 1.37.1 |

Products: Mediawiki Mediawiki.

## How do I fix CVE-2021-46149?

Upgrade mediawiki to a fixed version for your release line: 1.35.5, 1.36.3 or 1.37.1.

## Is CVE-2021-46149 being exploited?

There is no known exploitation of CVE-2021-46149 in the wild and no public exploit code.

## Other vulnerabilities in Mediawiki Mediawiki

- [CVE-2023-37303](https://insights.sbomify.com/CVE-2023-37303/): Denial of service in n/a (critical 9.8)
- [CVE-2022-29904](https://insights.sbomify.com/CVE-2022-29904/): SQL injection in n/a (critical 9.8)
- [CVE-2022-29906](https://insights.sbomify.com/CVE-2022-29906/): Missing authorization in n/a (critical 9.8)
- [CVE-2022-28205](https://insights.sbomify.com/CVE-2022-28205/): Business logic in n/a (critical 9.8)
- [CVE-2022-28206](https://insights.sbomify.com/CVE-2022-28206/): Missing authorization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-46149 and fix it if it is affected.

What it is: CVE-2021-46149 is a high-severity denial of service vulnerability in Mediawiki Mediawiki, published on 7 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-46149 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.35.5, 1.36.3, 1.37.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-46149/ (Markdown: https://insights.sbomify.com/CVE-2021-46149/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-46149
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-46149
- OSV: https://osv.dev/vulnerability/CVE-2021-46149

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-46149/
Summaries are generated and may contain mistakes; the official description above is the record.
