CVE-2021-46150 Cross-site scripting in n/a
Cross-site scripting in MediaWiki's CheckUserLog allows attackers to execute arbitrary scripts via date mishandling, potentially compromising user accounts.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-46150?
CVE-2021-46150 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 7 Jan 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
An issue was discovered in MediaWiki before 1.35.5, 1.36.x before 1.36.3, and 1.37.x before 1.37.1. Special:CheckUserLog allows CheckUser XSS because of date mishandling, as demonstrated by an XSS payload in MediaWiki:October.
Weakness: CWE-79
Which versions are affected by CVE-2021-46150?
1 open source package ship an affected version, including mediawiki. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki Bitnami | All versions | 1.35.5, 1.36.3, 1.37.1 |
Products include Mediawiki Mediawiki.
How do I fix CVE-2021-46150?
Upgrade mediawiki to a fixed version for your release line: 1.35.5, 1.36.3 or 1.37.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-46150 being exploited?
There is no known exploitation of CVE-2021-46150 in the wild and no public exploit code.
Other vulnerabilities in Mediawiki Mediawiki
Sources
Also known as BIT-mediawiki-2021-46150, GHSA-74qj-pmvq-g8v5.