CVE-2021-46659 Denial of service in n/a
An attacker can cause a MariaDB application crash by exploiting a logic error in view nesting levels, leading to denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-46659?
CVE-2021-46659 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 29 Jan 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
MariaDB before 10.7.2 allows an application crash because it does not recognize that SELECT_LEX::nest_level is local to each VIEW.
Which versions are affected by CVE-2021-46659?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | From 5.5.0 | 10.2.42, 10.3.33, 10.4.23, 10.5.14, 10.6.6, 10.7.2 |
mariadb-min Bitnami | From 5.5.0 | 10.2.42, 10.3.33, 10.4.23, 10.5.14, 10.6.6, 10.7.2 |
mysql-client Bitnami | From 5.5.0 | 10.2.42, 10.3.33, 10.4.23, 10.5.14, 10.6.6, 10.7.2 |
Products include Fedoraproject Fedora, Mariadb Mariadb.
How do I fix CVE-2021-46659?
Upgrade mariadb to a fixed version for your release line: 10.2.42, 10.3.33, 10.4.23 or 10.5.14.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-46659 being exploited?
There is no known exploitation of CVE-2021-46659 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as ALPINE-CVE-2021-46659, AZL-8454, BIT-mariadb-2021-46659, BIT-mariadb-min-2021-46659, BIT-mysql-client-2021-46659, DEBIAN-CVE-2021-46659 and 2 more.