{"answers":{"affected":"3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-46662 in the wild and no public exploit code.","fix":"Upgrade mariadb to a fixed version for your release line: 10.3.32, 10.4.22, 10.5.13 or 10.6.5.","what":"CVE-2021-46662 is a medium-severity denial of service vulnerability in Mariadb Mariadb, published on 1 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-46662 and fix it if it is affected.\n\nWhat it is: CVE-2021-46662 is a medium-severity denial of service vulnerability in Mariadb Mariadb, published on 1 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-46662 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mariadb (Bitnami): affected from 10.3.0; fixed in 10.3.32, 10.4.22, 10.5.13, 10.6.5\n- mariadb-min (Bitnami): affected from 10.3.0; fixed in 10.3.32, 10.4.22, 10.5.13, 10.6.5\n- mysql-client (Bitnami): affected from 10.3.0; fixed in 10.3.32, 10.4.22, 10.5.13, 10.6.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-46662/ (Markdown: https://insights.sbomify.com/CVE-2021-46662/index.md)","id":"CVE-2021-46662","markdown":"https://insights.sbomify.com/CVE-2021-46662/index.md","name":"CVE-2021-46662","record":{"aliases":["ALPINE-CVE-2021-46662","AZL-8406","BIT-mariadb-2021-46662","BIT-mariadb-min-2021-46662","BIT-mysql-client-2021-46662","DEBIAN-CVE-2021-46662","GHSA-p388-7w8m-f48h","UBUNTU-CVE-2021-46662"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"MariaDB database","requires_auth":"low_privilege","summary":"An attacker can cause a MariaDB application crash by executing a specific UPDATE statement with a nested subquery, leading to denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mariadb","vendor":"mariadb"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"MariaDB through 10.5.9 allows a set_var.cc application crash via certain uses of an UPDATE statement in conjunction with a nested subquery.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2021-46662","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"mariadb:mariadb","products":["mariadb:mariadb"],"type":"denial_of_service","year":"2021"},"n_packages":3,"n_references":3,"next":{"headline":"Denial of service in n/a","id":"CVE-2021-46663"},"packages":[{"ecosystem":"Bitnami","fixed":["10.3.32","10.4.22","10.5.13","10.6.5"],"introduced":["10.3.0","10.4.0","10.5.0","10.6.0"],"last_affected":[],"package":"mariadb","purl":"pkg:bitnami/mariadb","source":"BIT-mariadb-2021-46662"},{"ecosystem":"Bitnami","fixed":["10.3.32","10.4.22","10.5.13","10.6.5"],"introduced":["10.3.0","10.4.0","10.5.0","10.6.0"],"last_affected":[],"package":"mariadb-min","purl":"pkg:bitnami/mariadb-min","source":"BIT-mariadb-min-2021-46662"},{"ecosystem":"Bitnami","fixed":["10.3.32","10.4.22","10.5.13","10.6.5"],"introduced":["10.3.0","10.4.0","10.5.0","10.6.0"],"last_affected":[],"package":"mysql-client","purl":"pkg:bitnami/mysql-client","source":"BIT-mysql-client-2021-46662"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2021-46661"},"products":["n/a"],"published":"2022-02-01","related":[{"cvss_score":10,"headline":"MariaDB server has unsafe parameter handling in `wsrep_notify_cmd`","id":"CVE-2026-49261","kev_date_added":null,"published":"2026-06-11"},{"cvss_score":9.9,"headline":"MariaDB: Out-of-bound buffer write on in `ST_AsText` of nested GeometryCollections","id":"CVE-2026-85746","kev_date_added":null,"published":"2026-10-16"},{"cvss_score":9.9,"headline":"MariaDB: Use-after-free with a large number of SYS_REFCURSOR's","id":"CVE-2026-85748","kev_date_added":null,"published":"2026-10-16"},{"cvss_score":9.9,"headline":"MariaDB: Numerous issues caused by historical #mysql50# tablename encoding bypass.","id":"CVE-2026-92262","kev_date_added":null,"published":"2026-10-16"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2023-26785","kev_date_added":null,"published":"2024-10-17"},{"cvss_score":8.8,"headline":"MariaDB: GRANT PROXY with empty password incorrectly checks grantor's privileges","id":"CVE-2026-97380","kev_date_added":null,"published":"2026-10-16"},{"cvss_score":8.6,"headline":"Heap-based Buffer Overflow in MariaDB","id":"CVE-2026-32710","kev_date_added":null,"published":"2026-03-20"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"An attacker can cause a MariaDB application crash by executing a specific UPDATE statement with a nested subquery, leading to denial of service.","url":"https://insights.sbomify.com/CVE-2021-46662/"}