CVE-2021-46663 Denial of service in n/a
An attacker can cause a MariaDB application crash via specific SELECT statements, leading to denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-46663?
CVE-2021-46663 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 1 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
MariaDB through 10.5.13 allows a ha_maria::extra application crash via certain SELECT statements.
Which versions are affected by CVE-2021-46663?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | From 10.2.41 | 10.2.43, 10.3.34, 10.4.24, 10.5.15, 10.6.7, 10.7.3 |
mariadb-min Bitnami | From 10.2.41 | 10.2.43, 10.3.34, 10.4.24, 10.5.15, 10.6.7, 10.7.3 |
mysql-client Bitnami | From 10.2.41 | 10.2.43, 10.3.34, 10.4.24, 10.5.15, 10.6.7, 10.7.3 |
Products include Fedoraproject Fedora, Mariadb Mariadb.
How do I fix CVE-2021-46663?
Upgrade mariadb to a fixed version for your release line: 10.2.43, 10.3.34, 10.4.24 or 10.5.15.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-46663 being exploited?
There is no known exploitation of CVE-2021-46663 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as ALPINE-CVE-2021-46663, AZL-8407, BIT-mariadb-2021-46663, BIT-mariadb-min-2021-46663, BIT-mysql-client-2021-46663, DEBIAN-CVE-2021-46663 and 2 more.