CVE-2021-46669 Use after free in n/a
Attackers can trigger a use-after-free vulnerability in MariaDB when using the BIGINT data type, potentially leading to code execution or denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-46669?
CVE-2021-46669 is a high-severity use after free vulnerability in Debian Debian Linux, published on 1 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
MariaDB through 10.5.9 allows attackers to trigger a convert_const_to_int use-after-free when the BIGINT data type is used.
Weakness: CWE-416
Which versions are affected by CVE-2021-46669?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | All versions | 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
mariadb-min Bitnami | All versions | 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
mysql-client Bitnami | All versions | 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
Products include Debian Debian Linux, Fedoraproject Fedora, Mariadb Mariadb.
How do I fix CVE-2021-46669?
Upgrade mariadb to a fixed version for your release line: 10.2.44, 10.3.35, 10.4.25 or 10.5.16.
Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.
Is CVE-2021-46669 being exploited?
There is no known exploitation of CVE-2021-46669 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as AZL-8413, BIT-mariadb-2021-46669, BIT-mariadb-min-2021-46669, BIT-mysql-client-2021-46669, DEBIAN-CVE-2021-46669, GHSA-wrw9-g9r9-p9h2 and 1 more.