# CVE-2021-46669: Use after free in n/a

> Attackers can trigger a use-after-free vulnerability in MariaDB when using the BIGINT data type, potentially leading to code execution or denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Feb 2022
- **Updated:** 4 Aug 2024
- **Also known as:** AZL-8413, BIT-mariadb-2021-46669, BIT-mariadb-min-2021-46669, BIT-mysql-client-2021-46669, DEBIAN-CVE-2021-46669, GHSA-wrw9-g9r9-p9h2, UBUNTU-CVE-2021-46669

## What is CVE-2021-46669?

CVE-2021-46669 is a high-severity use after free vulnerability in Debian Debian Linux, published on 1 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MariaDB through 10.5.9 allows attackers to trigger a convert_const_to_int use-after-free when the BIGINT data type is used.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2021-46669?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb` | Bitnami | All versions | 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
| `mariadb-min` | Bitnami | All versions | 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |
| `mysql-client` | Bitnami | All versions | 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4 |

Products: Debian Debian Linux, Fedoraproject Fedora, Mariadb Mariadb.

## How do I fix CVE-2021-46669?

Upgrade mariadb to a fixed version for your release line: 10.2.44, 10.3.35, 10.4.25 or 10.5.16.

## Is CVE-2021-46669 being exploited?

There is no known exploitation of CVE-2021-46669 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-46669 and fix it if it is affected.

What it is: CVE-2021-46669 is a high-severity use after free vulnerability in Debian Debian Linux, published on 1 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-46669 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb (Bitnami): affected all versions; fixed in 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4
- mariadb-min (Bitnami): affected all versions; fixed in 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4
- mysql-client (Bitnami): affected all versions; fixed in 10.2.44, 10.3.35, 10.4.25, 10.5.16, 10.6.8, 10.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-46669/ (Markdown: https://insights.sbomify.com/CVE-2021-46669/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-46669
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-46669
- OSV: https://osv.dev/vulnerability/CVE-2021-46669

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-46669/
Summaries are generated and may contain mistakes; the official description above is the record.
