# CVE-2021-46704: OS Command Injection in GenieACS

> Unauthenticated attackers can execute arbitrary OS commands via the ping host argument in the GenieACS UI API due to insufficient input validation.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2022
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-2877-693q-pj33

## What is CVE-2021-46704?

CVE-2021-46704 is a critical command injection vulnerability in n/a, published on 6 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In GenieACS 1.2.x before 1.2.8, the UI interface API is vulnerable to unauthenticated OS command injection via the ping host argument (lib/ui/api.ts and lib/ping.ts). The vulnerability arises from insufficient input validation combined with a missing authorization check.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2021-46704?

2 open source packages ship an affected version, including genieacs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `genieacs` | npm | All versions | 1.2.8 |
| `genieacs` | npm | All versions | 1.2.8 |

Products: Genieacs Genieacs.

## How do I fix CVE-2021-46704?

Upgrade genieacs to 1.2.8 or later.

## Is CVE-2021-46704 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-46704 exists.

Public exploit code:

- CVE-2021-46704 GenieACS Command Injection POC (github_poc): https://github.com/MithatGuner/CVE-2021-46704-POC
- CVE-2021-46704 Nuclei template (github_poc): https://github.com/Erenlancaster/CVE-2021-46704
- GenieACS => 1.2.8 - OS Command Injection (nuclei): http/cves/2021/CVE-2021-46704.yaml

## Other vulnerabilities in n/a

- [CVE-2025-56015](https://insights.sbomify.com/CVE-2025-56015/): GenieACS has an unauthenticated access vulnerability via the NBI API endpoint (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-46704 and fix it if it is affected.

What it is: CVE-2021-46704 is a critical command injection vulnerability in n/a, published on 6 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-46704 exists.

Affected packages and fixed versions:
- genieacs (npm): affected all versions; fixed in 1.2.8
- genieacs (npm): affected all versions; fixed in 1.2.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-46704/ (Markdown: https://insights.sbomify.com/CVE-2021-46704/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-46704
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-46704
- OSV: https://osv.dev/vulnerability/CVE-2021-46704

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-46704/
Summaries are generated and may contain mistakes; the official description above is the record.
